Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

make install fails on fedora 11 #1

Open
ngerakines opened this Issue Oct 29, 2009 · 1 comment

Comments

Projects
None yet
1 participant

After running a fresh make, I try to run sudo make install and get a bunch of errors trying to find erl. The erl and erlc executables in the /usr/local/ search path and can be found when running them with sudo as is.

[ngerakines@localhost jacobvorreuter-emongo]$ make
sh ebin/emongo.app.in 0.0.1
mkdir -p ebin/
(cd src;make)
make[1]: Entering directory `/home/ngerakines/code/jacobvorreuter-emongo/src'
erlc -W -I ../include -pa ../ebin +debug_info -o ../ebin emongo_app.erl
erlc -W -I ../include -pa ../ebin +debug_info -o ../ebin emongo_bson.erl
erlc -W -I ../include -pa ../ebin +debug_info -o ../ebin emongo_conn.erl
erlc -W -I ../include -pa ../ebin +debug_info -o ../ebin emongo.erl
erlc -W -I ../include -pa ../ebin +debug_info -o ../ebin emongo_packet.erl
make[1]: Leaving directory `/home/ngerakines/code/jacobvorreuter-emongo/src'
erl -pa ebin -noshell -run emongo_app build_rel -s init stop
[ngerakines@localhost jacobvorreuter-emongo]$ ls
ebin  emongo.boot  emongo.rel  emongo.script  include  Makefile  priv  README.markdown  src  support  t
[ngerakines@localhost jacobvorreuter-emongo]$ sudo make install
/bin/sh: erl: command not found
/bin/sh: erl: command not found
/bin/sh: erl: command not found
for i in ebin/*.beam include/*.hrl ebin/*.app; do install $i /`erl -eval 'io:format("~s~n", [code:lib_dir()])' -s init stop -noshell`/emongo-0.0.1/$i ; done
/bin/sh: erl: command not found
/bin/sh: erl: command not found
/bin/sh: erl: command not found
/bin/sh: erl: command not found
/bin/sh: erl: command not found
/bin/sh: erl: command not found
/bin/sh: erl: command not found
cp *.boot /`erl -eval 'io:format("~s~n", [code:root_dir()])' -s init stop -noshell`/bin/
/bin/sh: erl: command not found

There's nothing funky or special about my Erlang install. It was installed from source with the standard ./configure && make && sudo make install/.

It's worth mentioning that the result of sudo make install installed it into the root directory.

[ngerakines@localhost jacobvorreuter-emongo]$ ls /
bin  boot  data  dev  emongo-0.0.1  etc  home  lib  lib64  lost+found  media  mnt  opt  proc  root  sbin  selinux  srv  sys  tmp  usr  var

@master master referenced this issue in socialabs/emongo Apr 11, 2012

@master master Merge pull request #1 from jdhood1/master
Added performance test and cleaned up data left behind by other tests
52677dd

@tsujigiri tsujigiri pushed a commit to tsujigiri/emongo that referenced this issue Jul 17, 2013

@jdhood1 jdhood1 Merge pull request #1 from reflexsystems/master
i have no idea if you want these changes or not
02a3de6
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment