Permalink
Browse files

[enhance] qmlSimpleSlicer: change predefined check level warnings and…

… errors, default level is 'normal'

CHANGELOG the code slicer has a predefined set of slicer check levels, see --slicer-check to help you maintaining safe and fast client/server code
  • Loading branch information...
OpaOnWindowsNow committed Mar 26, 2012
1 parent 6caead4 commit ed813886cc52d80c2e7ebbb4d0f1b91ef66bbb4c
Showing with 6 additions and 6 deletions.
  1. +6 −6 qmlslicer/qmlSimpleSlicer.ml
@@ -162,16 +162,16 @@ module WClass = struct
all_swclass
);
"normal", (
- [Exposed.misleading],
- [Server.useless; Server.meaningless; Protected.misleading;Protected.implicit_access]
+ [Exposed.misleading; Server.misleading; Protected.implicit_access; Server.misleading],
+ [Protected.misleading]
);
"high", (
- [],
- [Exposed.misleading;Protected.implicit_access]
+ [Exposed.misleading],
+ [Server.misleading;Protected.implicit_access]
);
"higher", (
[],
- [Protected.implicit_access]
+ [Exposed.misleading;Protected.implicit_access]
);
"pedantic", (
[],
@@ -210,7 +210,7 @@ module Options = struct
include Type
let default_options = {
- check_level = "warnall"
+ check_level = "normal"
}
let _ = WClass.select_security_level default_options.check_level

0 comments on commit ed81388

Please sign in to comment.