Permalink
Browse files

Gemspec changes for mailer

  • Loading branch information...
1 parent ec662d3 commit 3a7a0482b33fb548685a680e1068b443d4898d21 @bryanp bryanp committed Nov 19, 2011
Showing with 33 additions and 0 deletions.
  1. +3 −0 pakyow-mailer/CHANGES
  2. 0 pakyow-mailer/README
  3. +29 −0 pakyow-mailer/pakyow-mailer.gemspec
  4. +1 −0 pakyow.gemspec
View
@@ -0,0 +1,3 @@
+= 0.7.0 / 2011-11-19
+
+ * Initial gem release
View
No changes.
@@ -0,0 +1,29 @@
+version = File.read(File.join(File.expand_path("../../VERSION", __FILE__))).strip
+presenter_path = File.exists?('pakyow-mailer') ? 'pakyow-mailer' : '.'
+
+Gem::Specification.new do |s|
+ s.platform = Gem::Platform::RUBY
+ s.name = 'pakyow-mailer'
+ s.version = version
+ s.summary = 'pakyow-mailer'
+ s.description = 'pakyow-mailer'
+ s.required_ruby_version = '>= 1.8.7'
+
+ s.authors = ['Bryan Powell', 'Bret Young']
+ s.email = 'bryan@metabahn.com'
+ s.homepage = 'http://pakyow.com'
+ s.rubyforge_project = 'pakyow-mailer'
+
+ s.files = Dir[
+ File.join(presenter_path, 'CHANGES'),
+ File.join(presenter_path, 'README'),
+ File.join(presenter_path, 'MIT-LICENSE'),
+ File.join(presenter_path, 'lib','**','*')
+ ]
+
+ s.require_path = File.join(presenter_path, 'lib')
+
+ s.add_dependency('pakyow-core', version)
+ s.add_dependency('pakyow-presenter', version)
+ s.add_dependency('mail', '~> 2.3')
+end
View
@@ -20,4 +20,5 @@ Gem::Specification.new do |s|
s.add_dependency('pakyow-core', version)
s.add_dependency('pakyow-presenter', version)
+ s.add_dependency('pakyow-mailer', version)
end

0 comments on commit 3a7a048

Please sign in to comment.