does not work with api version 1.1 #161

Open
araneta opened this Issue Oct 22, 2012 · 5 comments

Comments

Projects
None yet
4 participants
@araneta

araneta commented Oct 22, 2012

I got this error when trying to authenticate a user:
object(EpiTwitterJson)#24 (4) { ["resp":"EpiTwitterJson":private]=> object(EpiCurlManager)#25 (2) { ["key":"EpiCurlManager":private]=> string(15) "Resource id #47" ["epiCurl":"EpiCurlManager":private]=> object(EpiCurl)#21 (6) { ["mc":"EpiCurl":private]=> resource(45) of type (curl_multi) ["msgs":"EpiCurl":private]=> NULL ["running":"EpiCurl":private]=> NULL ["requests":"EpiCurl":private]=> array(2) { ["Resource id #46"]=> resource(46) of type (curl) ["Resource id #47"]=> resource(47) of type (curl) } ["responses":"EpiCurl":private]=> array(2) { ["Resource id #46"]=> array(5) { ["data"]=> string(159) "oauth_token=110686696-xxxxx&oauth_token_secret=xxxx&user_id=110686696&screen_name=ujianku" ["code"]=> int(200) ["time"]=> float(0.509702) ["length"]=> float(159) ["type"]=> string(24) "text/html; charset=utf-8" } ["Resource id #47"]=> array(5) { ["data"]=> string(68) "{"errors":[{"message":"Sorry, that page does not exist","code":34}]}" ["code"]=> int(404) ["time"]=> float(0.361124) ["length"]=> float(68) ["type"]=> string(31) "application/json; charset=utf-8" } } ["properties":"EpiCurl":private]=> array(4) { ["code"]=> int(2097154) ["time"]=> int(3145731) ["length"]=> int(3145743) ["type"]=> int(1048594) } } } ["responseText"]=> string(68) "{"errors":[{"message":"Sorry, that page does not exist","code":34}]}" ["response"]=> array(1) { ["errors"]=> array(1) { [0]=> array(2) { ["message"]=> string(31) "Sorry, that page does not exist" ["code"]=> int(34) } } } ["errors"]=> array(1) { [0]=> array(2) { ["message"]=> string(31) "Sorry, that page does not exist" ["code"]=> int(34) } } }

what should I do?

@chekalskiy

This comment has been minimized.

Show comment Hide comment
@chekalskiy

chekalskiy Oct 24, 2012

Show your request! At 20 October they shut down non-api.twitter.com-based methods

Show your request! At 20 October they shut down non-api.twitter.com-based methods

@huseyinbabal

This comment has been minimized.

Show comment Hide comment
@huseyinbabal

huseyinbabal Jun 12, 2013

I had similar issue. After updating

protected $apiVersion     = '1';

to

protected $apiVersion     = '1.1';

in EpiTwitter.php it works now.

I had similar issue. After updating

protected $apiVersion     = '1';

to

protected $apiVersion     = '1.1';

in EpiTwitter.php it works now.

@ghost

This comment has been minimized.

Show comment Hide comment
@ghost

ghost Jun 18, 2013

Any updates on the unit tests? Changing $apiVersion to 1.1 still doesn't fix it here.

ghost commented Jun 18, 2013

Any updates on the unit tests? Changing $apiVersion to 1.1 still doesn't fix it here.

@jmathai

This comment has been minimized.

Show comment Hide comment
@jmathai

jmathai Jul 3, 2013

Owner

@bc173 Can you clarify which calls don't work?

Owner

jmathai commented Jul 3, 2013

@bc173 Can you clarify which calls don't work?

@ghost

This comment has been minimized.

Show comment Hide comment
@ghost

ghost Jul 8, 2013

The whole thing just doesn't work any more. I switched over to another PHP library. I don't understand why you still keep this library up as it's completely broken and you seem to have no time to fix it...

ghost commented Jul 8, 2013

The whole thing just doesn't work any more. I switched over to another PHP library. I don't understand why you still keep this library up as it's completely broken and you seem to have no time to fix it...

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment