Permalink
Browse files

Prepare pyfakefs for version 3.4 development.

  • Loading branch information...
jmcgeheeiv committed Nov 13, 2017
1 parent ec96e85 commit 335da4bf271946c729ce3a65d60428ecdfd43592
Showing with 19 additions and 4 deletions.
  1. +11 −0 CHANGES.md
  2. +5 −3 README.md
  3. +1 −1 pyfakefs/fake_filesystem.py
  4. +2 −0 setup.cfg
View
@@ -1,6 +1,17 @@
# pyfakefs Release Notes
The release versions are PyPi releases.
## Version 3.4 (as yet unreleased)
This version of pyfakefs does not support Python 2.6. Python 2.6 users
must use pyfakefs 3.3 or earlier.
#### New Features
#### Infrastructure
#### Fixes
## [Version 3.3](https://pypi.python.org/pypi/pyfakefs/3.3)
This is the last release that supports Python 2.6.
View
@@ -139,9 +139,11 @@ For example, pyfakefs will not work with [`lxml`](http://lxml.de/). In this cas
### Continuous integration
pyfakefs is currently automatically tested with Python 2.6, 2.7, 3.3 and above under Linux, with Python 2.7 and 3.6 under MacOSX,
and with Python 2.7, 3.3 and 3.6 under Windows.
It is currently [![Build Status](https://travis-ci.org/jmcgeheeiv/pyfakefs.svg)](https://travis-ci.org/jmcgeheeiv/pyfakefs).
pyfakefs is currently automatically tested with:
* On Linux, with Python 2.6, 2.7, 3.3 and above using [Travis](https://travis-ci.org/jmcgeheeiv/pyfakefs).
It is currently [![Build Status](https://travis-ci.org/jmcgeheeiv/pyfakefs.svg)](https://travis-ci.org/jmcgeheeiv/pyfakefs).
* On MacOS, with Python 3.4 and 3.6
* On Windows, with Python 2.7, 3.3 and 3.6 using [Appveyor](https://ci.appveyor.com/project/jmcgeheeiv/pyfakefs)
See [Travis-CI](http://travis-ci.org) for
[test results for each Python version](https://travis-ci.org/jmcgeheeiv/pyfakefs).
@@ -107,7 +107,7 @@
__pychecker__ = 'no-reimportself'
__version__ = '3.3'
__version__ = '3.4'
PERM_READ = 0o400 # Read permission bit.
PERM_WRITE = 0o200 # Write permission bit.
View
@@ -0,0 +1,2 @@
[metadata]
description-file = README.md

0 comments on commit 335da4b

Please sign in to comment.