Skip to content

Required XML::LibXML version #3

runrig opened this Issue Aug 15, 2012 · 2 comments

2 participants

runrig commented Aug 15, 2012

The Makefile.PL requires version 1.89 of XML::LibXML. Just wanted to say that for perl version 5.8.8, I only have XML::LibXML version 1.84, and all tests for Excel::Reader::XLSX pass, so you can probably downgrade this version requirement.


I really only picked the version that was current when I installed XML::LibXML to ensure that anyone testing it was at least on the same level as me.

So in principal I could drop it back to any earlier version that passed the tests.

However, I think I saw an optimisation/extension in a recent version of XML::LibXML that would improve overall performance so I may actually increase the required version.

XML::LibXML isn't core so it shouldn't matter which version is specified, right?

runrig commented Aug 30, 2012

I can't easily upgrade the library on the system I use since I'm not the admin (though I was at the time I installed it, so I installed the latest version at the time), so I would go with trying to requiring the lowest possible version that works, but maybe recommending some later version. Requiring a later version may dissuade some people (less open minded than me) from installing the library. IMHO, so it's all up to you :-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.