Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Failing with Maven version #360

Closed
siva90144 opened this issue Feb 13, 2020 · 9 comments
Closed

Failing with Maven version #360

siva90144 opened this issue Feb 13, 2020 · 9 comments
Labels

Comments

@siva90144
Copy link

@siva90144 siva90144 commented Feb 13, 2020

When reporting an issue:

  • Mention versions of Java, JMeter, Maven and JMeter-Maven-Plugin
  • Provide pom.xml and any log file (jmeter.log, maven logs)
  • Explain clearly the reproducer:
    • What should happen (OK Case)
    • What happens (KO Case)
  • Answer to questions of the person who handles your case
    Java: 1.8.0_231
    Jmeter: 5.1.1
    Maven: 3.5.4
    JMeter-Maven-Plugin: 3.0.0

And running through maven goal as clean verify. it throwing following error.

The plugin com.lazerycode.jmeter:jmeter-maven-plugin:3.0.0 requires Maven version 3.5.2 -> [Help 1]

Issue are related to bug, it is not the right place to ask questions about usage, for the latter 👍

@siva90144

This comment has been minimized.

Copy link
Author

@siva90144 siva90144 commented Feb 13, 2020

pom.txt
here is my pom.xml

<project>
 <build>
        <plugins>
            <plugin>
                <groupId>com.lazerycode.jmeter</groupId>
                <artifactId>jmeter-maven-plugin</artifactId>
                <version>3.0.0</version>
                <executions>
                    <execution>
                        <id>jmeter-tests</id>
                        <phase>verify</phase>
                        <goals>
                            <goal>jmeter</goal>
                        </goals>
                    </execution>
                </executions>
            </plugin>
        </plugins>
     </build>
</project>
@Ardesco Ardesco added the invalid label Feb 14, 2020
@Ardesco

This comment has been minimized.

Copy link
Contributor

@Ardesco Ardesco commented Feb 14, 2020

Is the error not clear enough?

You need to install maven version 3.5.2 or higher

@Ardesco Ardesco closed this Feb 14, 2020
@siva90144

This comment has been minimized.

Copy link
Author

@siva90144 siva90144 commented Feb 14, 2020

@Ardesco

This comment has been minimized.

Copy link
Contributor

@Ardesco Ardesco commented Feb 14, 2020

Can you provide the output of mvn -version on your command line please.

I'm expecting to see something like this:

Apache Maven 3.6.3 (cecedd343002696d0abb50b32b541b8a6ba2883f)
Maven home: /usr/local/Cellar/maven/3.6.3/libexec
Java version: 13.0.2, vendor: Oracle Corporation, runtime: /Library/Java/JavaVirtualMachines/jdk-13.0.2.jdk/Contents/Home
Default locale: en_GB, platform encoding: UTF-8
OS name: "mac os x", version: "10.15.3", arch: "x86_64", family: "mac"

So I can see exactly what you are running

@siva90144

This comment has been minimized.

Copy link
Author

@siva90144 siva90144 commented Feb 14, 2020

here is the java and maven versions
Maven version

did I miss anything in pom.xml ?

@Ardesco

This comment has been minimized.

Copy link
Contributor

@Ardesco Ardesco commented Feb 14, 2020

Are you running mvn verify through the command line, or inside an IDE?

@Ardesco Ardesco reopened this Feb 14, 2020
@siva90144

This comment has been minimized.

Copy link
Author

@siva90144 siva90144 commented Feb 14, 2020

I am running it through eclipse IDE and command is clean verify

image

@Ardesco

This comment has been minimized.

Copy link
Contributor

@Ardesco Ardesco commented Feb 14, 2020

in that case can you look at Window –> Preferences –> Maven –> Installation and see what version of Maven has been bundled with Eclipse.

Also I would suggest that you try running a mvn verify through the command line, I expect everything will work there.

@Ardesco

This comment has been minimized.

Copy link
Contributor

@Ardesco Ardesco commented Feb 17, 2020

Closing as user error

@Ardesco Ardesco closed this Feb 17, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.