Permalink
Browse files

Made the ImageMagick requirement more prominent

  • Loading branch information...
1 parent fc792c8 commit beff1273889c2954c9c68e951641f8c5e705d223 Nathan Long committed Feb 11, 2011
Showing with 15 additions and 0 deletions.
  1. +15 −0 README.md
View
15 README.md
@@ -18,6 +18,21 @@ more detailed options.
The complete [RDoc](http://rdoc.info/gems/paperclip) is online.
+Requirements
+------------
+
+ImageMagick must be installed and Paperclip must have access to it. To ensure
+that it does, on your command line, run `which convert` (one of the ImageMagick
+utilities). This will give you the path where that utility is installed. For
+example, it might return `/usr/local/bin/convert`.
+
+Then, in your environment config file, let Paperclip know to look there by adding that
+directory to its path.
+
+In development mode, you might add this line to `config/environments/development.rb)`:
+
+ Paperclip.options[:command_path] = "/usr/local/bin/"
+
Installation
------------

0 comments on commit beff127

Please sign in to comment.