plugin_googlemap_J25_J3x.v3.3

@jmosmap jmosmap released this May 16, 2015 · 4 commits to master since this release

This is a new release of the Joomla plugin Google Maps by Reumer.
The support for Joomla 1.5 is removed. The file J25_J3x in the name is for Joomla 2.5/3.x.

The new version has the following new features:

  • Added option to sign in as google user to see map in own context
  • Added geo location of the visitor
  • Added direct directions based on location of visitor.
  • Added print button with parameter and language files
  • Added possibility to select icon/images in configuration of the plugin

Solves the following errors:

  • Solved infowindow of gotoAddress position and streetview location combined with visitors location
  • Placed language files in separate directories and solved bug with first install that description of plugin is not shown.
  • Return parsed xml of kml file in kml proxy
  • Added error handling if geocoding is giving an error not in XML format
  • Removed latitude ID etc. Not available anymore
  • Removed sensor, it is not required anymore for geolocation of the user
  • Removed Earth maptype because it is deprecated
  • Solution for loading google maps api after mootools framework to solve the bug in google maps api that controls are not shown (3.17/18) or on top of each other (3.19)
  • Solved bug that with one marker and no geolocation the map zooms to full detail level
  • Changed demo url and some wrong url to test website.
  • Solved warning on missing variable on print button
  • Google Earth Deprecated in December 2015
  • Always set google api version from .x to .exp
  • Always set google api version from 2 to 3
  • Added classes on the directions form for labels
  • Added support to change the google maps api url (because of some countries that block the general url like China)
  • Added fix for PHP changed external entity loading. This causes a warning when reading a local file. Switch to false to enable external entity loading.
  • Changed China url
  • Solved printing in IE, Safari and Opera and keep it in the same window
  • Language files migrated to 2.5
  • Removed 1.5 code
  • Language is now formal codes: country and language, so en-GB
  • Added gotoaddrtimeout parameter for time out of infowindow of gotoaddr. And added the option to show lat and lng.
  • Sortering kml weer gemaakt
  • Change the API script location to fixed maps.googleapis.com. This reduces cookies
  • Solved problem of top level kml files that where related to a parent instead of toplevel

The update will automatically update in Joomla 2.5/3.x.

If you use the plugin with version lower that 3.0 then please, read: http://tech.reumer.net/Google-Maps/Documentation-of-plugin-Googlemap/new-version-30-of-plugin-googlemaps-released.html

Language support for English, French, Italian, Spanish and Swedish for all the parameters. Please send language files thru my website so I can add them to the plugin.

plugin_googlemap_J25_J3x.v3.2

@jmosmap jmosmap released this Apr 1, 2015 · 10 commits to master since this release

This is a new release of the Joomla plugin Google Maps by Reumer.
This version restores the kml proxy feature in a secure way that was removed in the previous version because of security risks. Also it solves some problems for responsive templates.

The file with J15 in the name is for Joomla 1.5 and the file J25_J3x in the name is for Joomla 2.5/3.x.

The new version has the following new features:

Added language possibilities for GeoXML and gotoaddress form
Open infowindow in KML by parameter (GeoXML)
Solves the following errors:

New authorisation for Twitter
Security risks in kml proxy
Problem of standalone Joomla application for kml proxy, twitter and css settings
Problem with clouds
Standard use Google Maps API version stable instead of development
Support for language with multiple dialects (Portugese/Chinese)
Problem with zoom and center in lightbox
Solves problems with responsive templates
The update will automatically update in Joomla 2.5/3.x.
If you still use Joomla 1.5, you must update it yourself.

If you use the plugin with version lower that 3.0 then please, read: http://tech.reumer.net/Google-Maps/Documentation-of-plugin-Googlemap/new-version-30-of-plugin-googlemaps-released.html

Language support for English, French, Italian, Spanish and Swedish for all the parameters. Please send language files thru my website so I can add them to the plugin.