A simple but powerful macro language for text interpolation.
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
macrosql
.gitignore
LICENSE.txt
README.rst
requirements.txt
setup.cfg
setup.py

README.rst

macrosql

A simple but powerful macro language for text interpolation.

Installation

Here's what you need to do to install macrosql:

Python 3.6

macrosql is compatible with Python 3.6 and later.

On Unix systems, install Python 3.6 (or later) via your package manager (apt, rpm, yum, brew). Alternatively, you can download an installation package from the official Python downloads page.

Virtual Environment

It is recommended to put all project dependencies into its own virtual environment - this way we don't pollute the global Python installation. For this we recommend you use virtualenvwrapper. Follow the instructions here to get this installed. Once you have virtualenvwrapper install, create a new virtual environment with:

mkvirtualenv macrosql
workon macrosql

Now let's install macrosql:

pip install macrosql

Get help or give help

  • Open a new issue if you encounter a problem.
  • Pull requests welcome. You can help with language features!

License

  • macrosql is Free Software and licensed under the GPLv3.
  • Main author is @jmsmistral