Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Fetching contributors…

Cannot retrieve contributors at this time

87 lines (81 sloc) 3.333 kb
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = "apnmachine"
s.version = "0.1.1"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Julien Nakache"]
s.date = "2012-02-21"
s.description = "An APN server & library in which EventMachine daemons maintain a persistent connection to Apple servers and Redis acts as the glue with your Apps. See Readme for more info :)"
s.email = "julien.nakache@gmail.com"
s.executables = ["apnmachined"]
s.extra_rdoc_files = [
"README.textile"
]
s.files = [
"Gemfile",
"README.textile",
"Rakefile",
"apnmachine.gemspec",
"bin/apnmachined",
"lib/apnmachine.rb",
"lib/apnmachine/config.rb",
"lib/apnmachine/notification.rb",
"lib/apnmachine/server.rb",
"lib/apnmachine/server/client.rb",
"lib/apnmachine/server/error_response.rb",
"lib/apnmachine/server/response.rb",
"lib/apnmachine/server/server.rb",
"lib/apnmachine/server/server_connection.rb",
"lib/apnmachine/version.rb",
"test/helper.rb",
"test/test_apnmachine.rb"
]
s.homepage = "http://github.com/jnak/apnmachine"
s.licenses = ["MIT"]
s.require_paths = ["lib"]
s.rubygems_version = "1.8.17"
s.summary = "An APN server & library built on top of Redis and EventMachine"
if s.respond_to? :specification_version then
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<em-synchrony>, [">= 0"])
s.add_runtime_dependency(%q<daemons>, [">= 0"])
s.add_runtime_dependency(%q<yajl-ruby>, ["~> 1.1.0"])
s.add_runtime_dependency(%q<redis>, [">= 2.2.0"])
s.add_runtime_dependency(%q<hiredis>, [">= 0.3.1"])
s.add_runtime_dependency(%q<i18n>, [">= 0"])
s.add_development_dependency(%q<shoulda>, [">= 0"])
s.add_development_dependency(%q<rdoc>, ["~> 3.12"])
s.add_development_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_development_dependency(%q<jeweler>, ["~> 1.8.3"])
s.add_development_dependency(%q<simplecov>, [">= 0"])
else
s.add_dependency(%q<em-synchrony>, [">= 0"])
s.add_dependency(%q<daemons>, [">= 0"])
s.add_dependency(%q<yajl-ruby>, ["~> 1.1.0"])
s.add_dependency(%q<redis>, [">= 2.2.0"])
s.add_dependency(%q<hiredis>, [">= 0.3.1"])
s.add_dependency(%q<i18n>, [">= 0"])
s.add_dependency(%q<shoulda>, [">= 0"])
s.add_dependency(%q<rdoc>, ["~> 3.12"])
s.add_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_dependency(%q<jeweler>, ["~> 1.8.3"])
s.add_dependency(%q<simplecov>, [">= 0"])
end
else
s.add_dependency(%q<em-synchrony>, [">= 0"])
s.add_dependency(%q<daemons>, [">= 0"])
s.add_dependency(%q<yajl-ruby>, ["~> 1.1.0"])
s.add_dependency(%q<redis>, [">= 2.2.0"])
s.add_dependency(%q<hiredis>, [">= 0.3.1"])
s.add_dependency(%q<i18n>, [">= 0"])
s.add_dependency(%q<shoulda>, [">= 0"])
s.add_dependency(%q<rdoc>, ["~> 3.12"])
s.add_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_dependency(%q<jeweler>, ["~> 1.8.3"])
s.add_dependency(%q<simplecov>, [">= 0"])
end
end
Jump to Line
Something went wrong with that request. Please try again.