Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Add Ruby 2.1.0 to .travis.yml #1218

Closed
wants to merge 3 commits into from

5 participants

@salimane

No description provided.

@jnicklas
Owner

Seems like Ruby 2.1.0 is not building with the base versions Gemfile. @joliss, @twalpole I'm thinking that the base versions Gemfile maybe isn't worth the trouble. What do you think, should we kill it?

@twalpole
Collaborator

@jnicklas I'm rerunning the failed test since it failed trying to install the json gem which seems to install just fine under 2.1 for me, so it may just have been a spurious failure (will know once travis runs it again) - however while looking into this I did notice that since the rspec dependencies for 2.2 are setup as
Gem rspec-2.2.0
rspec-core (~> 2.2)
rspec-expectations (~> 2.2)
rspec-mocks (~> 2.2)

it actually just loads all the latest 2.14.x versions of rspec-core, expectations and mocks -- so its really not testing rspec 2.2 as a minimum version. That leaves rack, rack-test, nokogiri and cucumber as the packages its testing minimum versions of. For me its not really worth testing the minimum versions of them for a testing tool (I'd feel differently if capybara was a library used in production)

@twalpole
Collaborator

@jnicklas The rerun was fine, so this failure may have just been a temporary issue with travis

@joliss
Collaborator

@joliss, @twalpole I'm thinking that the base versions Gemfile maybe isn't worth the trouble.

Here's the original reasoning: I was assuming that at some point we'd accidentally use a feature that wasn't supported by the minimum version of a dependency, without bumping the version spec in Gemfile at the same time. So I added the base version Gemfile in order to avoid having to deal with issues like "Capybara breaks with old version of $dependency". In other words, it was intended as a time saver. If it's not saving time, we should perhaps remove it.

I don't believe the Gemfile.base-versions test has ever actually caught anything, has it? If it hasn't, perhaps that's evidence that we don't need it.

Then again, seeing @twalpole comment's, perhaps this issue is unrelated.

I'll leave it up to you all.

@jnicklas
Owner

I don't believe the Gemfile.base-versions test has ever actually caught anything, has it? If it hasn't, perhaps that's evidence that we don't need it.

I don't think it has. All the libraries we rely on are fairly old, stable libraries which don't have a lot of breaking changes. I vote for getting rid of it.

@twalpole
Collaborator

@jnicklas One thing to keep in mind is that we will probably want to test with both rspec 2 and 3 once 3 is final

@abotalov
Collaborator

It seems bundler is already on >= 1.5.1 at Travis.

Row 246 of https://travis-ci.org/jnicklas/capybara/jobs/17161920 says Using bundler (1.5.1)

@jnicklas
Owner

@twalpole true, but we don't have that much code which integrates with RSpec. When we make changes to it, we could just run that manually.

@abotalov what does the bundler version have to do with this?

@abotalov
Collaborator

This pull requests adds:
gem install bundler -v '>= 1.5.1' # Temporary workaround for gem installation error on ruby 2.1.0

But this row is not needed as Travis already has this version.

@salimane

@abotalov I've just added a commit to remove that temp work around.

@twalpole
Collaborator

Added 2.1.1 in #1283

@twalpole twalpole closed this
@salimane salimane deleted the branch
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Dec 31, 2013
  1. @salimane
Commits on Jan 6, 2014
  1. @salimane
Commits on Feb 3, 2014
  1. @salimane
This page is out of date. Refresh to see the latest.
Showing with 2 additions and 1 deletion.
  1. +2 −1  .travis.yml
View
3  .travis.yml
@@ -2,6 +2,7 @@ language: ruby
rvm:
- 1.9.3
- 2.0.0
+ - 2.1.0
- jruby-19mode
- rbx-2.1.1
- rbx-2.0.0
@@ -32,4 +33,4 @@ before_script:
- sh -e /etc/init.d/xvfb start
- export DISPLAY=:99.0
script: "bundle exec rake travis"
-
+
Something went wrong with that request. Please try again.