Skip to content


Subversion checkout URL

You can clone with
Download ZIP


Capybara was using an old selenium-webdriver #460

wants to merge 1 commit into from

4 participants


I found that capybara had installed selenium-webdriver version 0.2.2 as a dependency. This caused problems when trying to use firefox 6. The commit changes the dependency to 2.4.0 of selenium-webdriver.


+1 would love to see this working with FF6


No, the dependency is correct. As is, it will not match 0.2.2, since the dependency essentially boils down to >=2.0.0 && <3.0. Depending on ~>2.4.0 would be overspecifying the dependency. Just do a bundle update selenium-webdriver and you should get the latest version.

@jnicklas jnicklas closed this

This dependency has been confirmed and encouraged by @jarib, btw.


Yes, I was using version 1.0.0 of capybara so the solution was just to do a bundle update to use 1.0.1. Thanks.


weird, I've the same problem:

In my gemspec:

s.add_dependency(%q<selenium-webdriver>, ["~> 0.2.0"])

In your code:

s.add_runtime_dependency("selenium-webdriver", ["~> 2.0"])

When I get directly the gem from git, it works


@apneadiving: those two dependencies are incompatible, you can't satisfy both.


@jnicklas: Of course :)

I didn't touch anything though. That's why I deduce '2.0' is sometimes interpreted as '0.2.0'.


@apneadiving: it's not ;)


@apneadiving The dependency in capybara 1.0.0 was 0.2.0 so I suspect you were just using that.


@ramblex: correct! thanks :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Aug 18, 2011
  1. @ramblex
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  capybara.gemspec
2  capybara.gemspec
@@ -24,7 +24,7 @@ do |s|
s.add_runtime_dependency("nokogiri", [">= 1.3.3"])
s.add_runtime_dependency("mime-types", [">= 1.16"])
- s.add_runtime_dependency("selenium-webdriver", ["~> 2.0"])
+ s.add_runtime_dependency("selenium-webdriver", ["~> 2.4.0"])
s.add_runtime_dependency("rack", [">= 1.0.0"])
s.add_runtime_dependency("rack-test", [">= 0.5.4"])
s.add_runtime_dependency("xpath", ["~> 0.1.4"])
Something went wrong with that request. Please try again.