Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Require ruby 1.9 or higher #922

Merged
merged 1 commit into from

3 participants

@thegcat

As discussed in #781, see http://docs.rubygems.org/read/chapter/20#required_ruby_version for more info in required_ruby_version.

@jnicklas jnicklas merged commit 4258c0b into jnicklas:master

1 check was pending

Details default The Travis build is in progress
@thegcat

Great, thanks! :-)

@joliss
Collaborator

I think this will make it stop working with 1.8.7 altogether.

Jonas, do you want to release 3daca9e as 2.0.3 (as it contains a fix for 1.8.7 - see #921), and then we can bump the version to 2.1.0 with the new gemspec?

@joliss
Collaborator

So 2.0.3 would be the "last version with unofficial 1.8.7 support" or so.

@jnicklas
Owner

@joliss sounds sensible.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Jan 2, 2013
  1. @thegcat

    Require ruby 1.9 or higher

    thegcat authored
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 0 deletions.
  1. +1 −0  capybara.gemspec
View
1  capybara.gemspec
@@ -8,6 +8,7 @@ Gem::Specification.new do |s|
s.name = "capybara"
s.rubyforge_project = "capybara"
s.version = Capybara::VERSION
+ s.required_ruby_version = ">= 1.9.0"
s.authors = ["Jonas Nicklas"]
s.email = ["jonas.nicklas@gmail.com"]
Something went wrong with that request. Please try again.