Permalink
Browse files

adds version requirement to gherkin gem dependency. Gherkin gem prior…

… to version 2.5 did not include a Gherkin::Formatter::Model::Step#doc_string method. This causes turnip specs to fail when running on a system that has gherkin gem, but an older version. With gherkin v2.5 or greater, all turnip specs pass.
  • Loading branch information...
1 parent f3b63f9 commit e613733fd6f1bf96ff2f8b658563bce2b1c72c78 Kenton Newby committed Nov 24, 2011
Showing with 1 addition and 1 deletion.
  1. +1 −1 turnip.gemspec
View
@@ -19,6 +19,6 @@ Gem::Specification.new do |s|
s.require_paths = ["lib"]
s.add_runtime_dependency "rspec", "~>2.0"
- s.add_runtime_dependency "gherkin"
+ s.add_runtime_dependency "gherkin", ">= 2.5"
s.add_development_dependency "rake"
end

0 comments on commit e613733

Please sign in to comment.