Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Add travis. Update gemfile/spec helper to match.

  • Loading branch information...
commit 56294e6f2889693fa3fc797b0671b5231614cb4e 1 parent 964b0e1
@jnunemaker authored
Showing with 36 additions and 23 deletions.
  1. +9 −0 .travis.yml
  2. +7 −4 Gemfile
  3. +18 −17 Gemfile.lock
  4. +2 −2 spec/helper.rb
View
9 .travis.yml
@@ -0,0 +1,9 @@
+language: ruby
+rvm:
+ - 1.8.7
+ - ree
+ - 1.9.2
+ - 1.9.3
+notifications:
+ email: false
+bundler_args: --without development
View
11 Gemfile
@@ -1,12 +1,15 @@
source "http://rubygems.org"
gemspec
-group(:development) do
- gem 'rake'
- gem 'rspec', '~> 2.3'
+gem 'rake', '~> 0.9.0'
+
+gem 'mongo', '~> 1.6'
+gem 'bson_ext', '~> 1.6', :require => false
+
+group(:test) do
+ gem 'rspec', '~> 2.8'
gem 'log_buddy', '~> 0.5.0'
gem 'timecop', '~> 0.3.5'
gem 'i18n', '0.5.0'
gem 'activesupport', '~> 3', :require => 'active_support'
- gem 'bson_ext', :require => false
end
View
35 Gemfile.lock
@@ -10,23 +10,23 @@ GEM
specs:
activesupport (3.0.3)
adapter (0.5.2)
- bson (1.5.2)
- bson_ext (1.5.2)
- bson (= 1.5.2)
- diff-lcs (1.1.2)
+ bson (1.6.2)
+ bson_ext (1.6.2)
+ bson (~> 1.6.2)
+ diff-lcs (1.1.3)
i18n (0.5.0)
log_buddy (0.5.0)
- mongo (1.5.2)
- bson (= 1.5.2)
+ mongo (1.6.2)
+ bson (~> 1.6.2)
rake (0.9.2.2)
- rspec (2.4.0)
- rspec-core (~> 2.4.0)
- rspec-expectations (~> 2.4.0)
- rspec-mocks (~> 2.4.0)
- rspec-core (2.4.0)
- rspec-expectations (2.4.0)
- diff-lcs (~> 1.1.2)
- rspec-mocks (2.4.0)
+ rspec (2.9.0)
+ rspec-core (~> 2.9.0)
+ rspec-expectations (~> 2.9.0)
+ rspec-mocks (~> 2.9.0)
+ rspec-core (2.9.0)
+ rspec-expectations (2.9.1)
+ diff-lcs (~> 1.1.3)
+ rspec-mocks (2.9.0)
timecop (0.3.5)
PLATFORMS
@@ -35,9 +35,10 @@ PLATFORMS
DEPENDENCIES
activesupport (~> 3)
adapter-mongo!
- bson_ext
+ bson_ext (~> 1.6)
i18n (= 0.5.0)
log_buddy (~> 0.5.0)
- rake
- rspec (~> 2.3)
+ mongo (~> 1.6)
+ rake (~> 0.9.0)
+ rspec (~> 2.8)
timecop (~> 0.3.5)
View
4 spec/helper.rb
@@ -3,7 +3,7 @@
require 'rubygems'
require 'bundler'
-Bundler.require(:default, :development)
+Bundler.require(:default, :test)
require 'pathname'
require 'logger'
@@ -33,6 +33,6 @@
logger = Logger.new(log_path.join('test.log'))
LogBuddy.init(:logger => logger)
-Rspec.configure do |c|
+RSpec.configure do |c|
end
Please sign in to comment.
Something went wrong with that request. Please try again.