Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Updated layout of files based on this comment: http://railstips.org/b…

  • Loading branch information...
commit 8fe8241ed272ae9c34da326dcec23d9703716a86 1 parent 13ce703
@jnunemaker authored
View
2  Rakefile
@@ -1,7 +1,7 @@
require 'rubygems'
require 'rake'
require 'jeweler'
-require File.dirname(__FILE__) + '/lib/gemwhois/version'
+require File.dirname(__FILE__) + '/lib/gemwhois'
Jeweler::Tasks.new do |gem|
gem.name = 'gemwhois'
View
10 lib/gemwhois.rb
@@ -1,7 +1,3 @@
-require 'rubygems'
-require 'rubygems/command_manager'
-require 'rubygems/commands/whois'
-require 'crack'
-require 'unindent'
-
-Gem::CommandManager.instance.register_command(:whois)
+module Gemwhois
+ Version = '0.2.1'
+end
View
3  lib/gemwhois/version.rb
@@ -1,3 +0,0 @@
-module Gemwhois
- Version = '0.2'
-end
View
2  lib/rubygems/commands/whois.rb → lib/rubygems/commands/whois_command.rb
@@ -1,4 +1,6 @@
require 'rubygems/gemcutter_utilities'
+require 'crack'
+require 'unindent'
class Gem::Commands::WhoisCommand < Gem::Command
include Gem::GemcutterUtilities
View
3  lib/rubygems_plugin.rb
@@ -1,3 +1,4 @@
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.3.6')
- require File.join(File.dirname(__FILE__), 'gemwhois')
+ require 'rubygems/command_manager'
+ Gem::CommandManager.instance.register_command(:whois)
end
Please sign in to comment.
Something went wrong with that request. Please try again.