Skip to content


Subversion checkout URL

You can clone with
Download ZIP


happymapper 0.4.0 crashes ruby.exe on windows XP #23

crv opened this Issue · 5 comments

3 participants

crv commented

Ruby version 1.9.2
Rails 3.1.3
libxml-ruby (2.3.0 x86-mingw32)

Code causing problem (added the following code in application_controller.rb):

require 'rubygems'
require 'xml'
require 'happymapper'

xml = "<?xml version=\"1.0\" encoding=\"UTF-8\" standalone=\"yes\"?>sachin@abc.com111abc"
node = XML::Parser.string(xml).parse.root

crv commented

happymapper conflicts with libxml-ruby, libxml-ruby alone works fine until we require happymapper


Any updates on this...or fixes?


I am using nokogiri-happymapper for windows which uses nokogiri in-place of libxml-ruby.


Also it doesn't require anything to be changed in your app apart from an entry in the Gemfile


Excellent. Thanks!

@jnunemaker jnunemaker closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.