Skip to content


Subversion checkout URL

You can clone with
Download ZIP


Incompatible with Rails 3.2.3 #25

sdhull opened this Issue · 2 comments

1 participant

! rails c
/Users/sdhull/.rvm/gems/ruby-1.9.3-p194/gems/happymapper-0.4.0/lib/happymapper.rb:6:in `<top (required)>': Boolean is not a class (TypeError)
  from /Users/sdhull/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.1.4/lib/bundler/runtime.rb:68:in `require'
  from /Users/sdhull/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.1.4/lib/bundler/runtime.rb:68:in `block (2 levels) in require'
  from /Users/sdhull/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.1.4/lib/bundler/runtime.rb:66:in `each'
  from /Users/sdhull/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.1.4/lib/bundler/runtime.rb:66:in `block in require'
  from /Users/sdhull/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.1.4/lib/bundler/runtime.rb:55:in `each'
  from /Users/sdhull/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.1.4/lib/bundler/runtime.rb:55:in `require'
  from /Users/sdhull/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.1.4/lib/bundler.rb:119:in `require'
  from /Users/sdhull/Dev/project/config/application.rb:13:in `<top (required)>'

Just for reference, line 13 of application.rb is:

Bundler.require(*Rails.groups(:assets => %w(development test)))

Also, I've verified it's not a problem with this version of Ruby itself, as it loads fine in irb.


Aaaand Google produced a solution:

Of course, all I have to do is change around the order of my Gemfile (require happymapper first)! Silly me. :P

Workaround is OK, but not ideal.

@sdhull sdhull closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.