Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 30 lines (24 sloc) 1.225 kB
78f0c84 @jnunemaker Prepped for 0.2.5 release.
authored
1 # -*- encoding: utf-8 -*-
720e96a @jnunemaker Switch to bundler for release management and use hand made gemspec.
authored
2 $:.push File.expand_path("../lib", __FILE__)
3 require "httparty/version"
78f0c84 @jnunemaker Prepped for 0.2.5 release.
authored
4
e221365 @jnunemaker Adjusted post install. Tweaked example. Created gemspec for github. U…
authored
5 Gem::Specification.new do |s|
720e96a @jnunemaker Switch to bundler for release management and use hand made gemspec.
authored
6 s.name = "httparty"
7 s.version = HTTParty::VERSION
8 s.platform = Gem::Platform::RUBY
9 s.authors = ["John Nunemaker", "Sandro Turriate"]
10 s.email = ["nunemaker@gmail.com"]
11 s.homepage = "http://github.com/jnunemaker/httparty"
12 s.summary = %q{Makes http fun! Also, makes consuming restful web services dead easy.}
3c4f5ed @jnunemaker Made sure I got the manifest and gem stuff all right.
authored
13 s.description = %q{Makes http fun! Also, makes consuming restful web services dead easy.}
c69fe04 @jnunemaker Bumped version to 0.4.2 and prepped for release.
authored
14
720e96a @jnunemaker Switch to bundler for release management and use hand made gemspec.
authored
15 s.add_dependency 'crack', HTTParty::CRACK_DEPENDENCY
c69fe04 @jnunemaker Bumped version to 0.4.2 and prepped for release.
authored
16
720e96a @jnunemaker Switch to bundler for release management and use hand made gemspec.
authored
17 s.add_development_dependency "activesupport", "~> 2.3"
18 s.add_development_dependency "cucumber", "~> 0.7"
19 s.add_development_dependency "fakeweb", "~> 1.2"
20 s.add_development_dependency "rspec", "~> 1.3"
21 s.add_development_dependency "mongrel", "1.2.0.pre2"
d6b351f @sandro Version bump to 0.5.0
sandro authored
22
720e96a @jnunemaker Switch to bundler for release management and use hand made gemspec.
authored
23 s.post_install_message = "When you HTTParty, you must party hard!"
24
25 s.files = `git ls-files`.split("\n")
26 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
27 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
28 s.require_paths = ["lib"]
29 end
Something went wrong with that request. Please try again.