Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 41 lines (36 sloc) 2.418 kb
78f0c84 @jnunemaker Prepped for 0.2.5 release.
authored
1 # -*- encoding: utf-8 -*-
2
e221365 @jnunemaker Adjusted post install. Tweaked example. Created gemspec for github. Unco...
authored
3 Gem::Specification.new do |s|
4 s.name = %q{httparty}
78f0c84 @jnunemaker Prepped for 0.2.5 release.
authored
5 s.version = "0.2.5"
e221365 @jnunemaker Adjusted post install. Tweaked example. Created gemspec for github. Unco...
authored
6
e72ec5a @jnunemaker Updated manifest, history and gemspec for 0.1.8.
authored
7 s.required_rubygems_version = Gem::Requirement.new(">= 1.2") if s.respond_to? :required_rubygems_version=
e221365 @jnunemaker Adjusted post install. Tweaked example. Created gemspec for github. Unco...
authored
8 s.authors = ["John Nunemaker"]
78f0c84 @jnunemaker Prepped for 0.2.5 release.
authored
9 s.date = %q{2009-01-05}
10 s.default_executable = %q{httparty}
3c4f5ed @jnunemaker Made sure I got the manifest and gem stuff all right.
authored
11 s.description = %q{Makes http fun! Also, makes consuming restful web services dead easy.}
e72ec5a @jnunemaker Updated manifest, history and gemspec for 0.1.8.
authored
12 s.email = %q{nunemaker@gmail.com}
78f0c84 @jnunemaker Prepped for 0.2.5 release.
authored
13 s.executables = ["httparty"]
14 s.extra_rdoc_files = ["bin/httparty", "lib/core_extensions.rb", "lib/httparty/exceptions.rb", "lib/httparty/request.rb", "lib/httparty/version.rb", "lib/httparty.rb", "lib/module_level_inheritable_attributes.rb", "README"]
15 s.files = ["bin/httparty", "examples/aaws.rb", "examples/basic.rb", "examples/delicious.rb", "examples/google.rb", "examples/rubyurl.rb", "examples/twitter.rb", "examples/whoismyrep.rb", "History", "httparty.gemspec", "lib/core_extensions.rb", "lib/httparty/exceptions.rb", "lib/httparty/request.rb", "lib/httparty/version.rb", "lib/httparty.rb", "lib/module_level_inheritable_attributes.rb", "Manifest", "MIT-LICENSE", "Rakefile", "README", "setup.rb", "spec/as_buggery_spec.rb", "spec/fixtures/delicious.xml", "spec/fixtures/google.html", "spec/fixtures/twitter.json", "spec/fixtures/twitter.xml", "spec/httparty/request_spec.rb", "spec/httparty_spec.rb", "spec/spec.opts", "spec/spec_helper.rb", "website/css/common.css", "website/index.html"]
e221365 @jnunemaker Adjusted post install. Tweaked example. Created gemspec for github. Unco...
authored
16 s.has_rdoc = true
17 s.homepage = %q{http://httparty.rubyforge.org}
18 s.post_install_message = %q{When you HTTParty, you must party hard!}
e72ec5a @jnunemaker Updated manifest, history and gemspec for 0.1.8.
authored
19 s.rdoc_options = ["--line-numbers", "--inline-source", "--title", "Httparty", "--main", "README"]
e221365 @jnunemaker Adjusted post install. Tweaked example. Created gemspec for github. Unco...
authored
20 s.require_paths = ["lib"]
21 s.rubyforge_project = %q{httparty}
343ac9c @jnunemaker Prepped for 0.1.5 release.
authored
22 s.rubygems_version = %q{1.3.1}
3c4f5ed @jnunemaker Made sure I got the manifest and gem stuff all right.
authored
23 s.summary = %q{Makes http fun! Also, makes consuming restful web services dead easy.}
e221365 @jnunemaker Adjusted post install. Tweaked example. Created gemspec for github. Unco...
authored
24
25 if s.respond_to? :specification_version then
26 current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
27 s.specification_version = 2
28
343ac9c @jnunemaker Prepped for 0.1.5 release.
authored
29 if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
4113408 @jnunemaker Fixed weird uri normalizing issue that occurred when I was doing normali...
authored
30 s.add_runtime_dependency(%q<json>, ["~> 1.1"])
e72ec5a @jnunemaker Updated manifest, history and gemspec for 0.1.8.
authored
31 s.add_development_dependency(%q<echoe>, [">= 0"])
e221365 @jnunemaker Adjusted post install. Tweaked example. Created gemspec for github. Unco...
authored
32 else
4113408 @jnunemaker Fixed weird uri normalizing issue that occurred when I was doing normali...
authored
33 s.add_dependency(%q<json>, ["~> 1.1"])
e72ec5a @jnunemaker Updated manifest, history and gemspec for 0.1.8.
authored
34 s.add_dependency(%q<echoe>, [">= 0"])
e221365 @jnunemaker Adjusted post install. Tweaked example. Created gemspec for github. Unco...
authored
35 end
36 else
4113408 @jnunemaker Fixed weird uri normalizing issue that occurred when I was doing normali...
authored
37 s.add_dependency(%q<json>, ["~> 1.1"])
e72ec5a @jnunemaker Updated manifest, history and gemspec for 0.1.8.
authored
38 s.add_dependency(%q<echoe>, [">= 0"])
e221365 @jnunemaker Adjusted post install. Tweaked example. Created gemspec for github. Unco...
authored
39 end
e72ec5a @jnunemaker Updated manifest, history and gemspec for 0.1.8.
authored
40 end
Something went wrong with that request. Please try again.