Skip to content
This repository
Newer
Older
100644 24 lines (20 sloc) 0.936 kb
78f0c846 »
2009-01-05 Prepped for 0.2.5 release.
1 # -*- encoding: utf-8 -*-
720e96a6 »
2011-04-16 Switch to bundler for release management and use hand made gemspec.
2 $:.push File.expand_path("../lib", __FILE__)
3 require "httparty/version"
78f0c846 »
2009-01-05 Prepped for 0.2.5 release.
4
e2213650 »
2008-07-28 Adjusted post install. Tweaked example. Created gemspec for github. U…
5 Gem::Specification.new do |s|
720e96a6 »
2011-04-16 Switch to bundler for release management and use hand made gemspec.
6 s.name = "httparty"
7 s.version = HTTParty::VERSION
8 s.platform = Gem::Platform::RUBY
9 s.authors = ["John Nunemaker", "Sandro Turriate"]
10 s.email = ["nunemaker@gmail.com"]
fd2769ee »
2011-04-16 Forgot to set homepage.
11 s.homepage = "http://httparty.rubyforge.org/"
720e96a6 »
2011-04-16 Switch to bundler for release management and use hand made gemspec.
12 s.summary = %q{Makes http fun! Also, makes consuming restful web services dead easy.}
3c4f5edb »
2008-07-28 Made sure I got the manifest and gem stuff all right.
13 s.description = %q{Makes http fun! Also, makes consuming restful web services dead easy.}
c69fe04c »
2009-04-02 Bumped version to 0.4.2 and prepped for release.
14
05cacfee » bfrydl
2011-07-07 Use MultiXML and MultiJSON for parsing instead of Crack
15 s.add_dependency 'multi_json'
16 s.add_dependency 'multi_xml'
c69fe04c »
2009-04-02 Bumped version to 0.4.2 and prepped for release.
17
720e96a6 »
2011-04-16 Switch to bundler for release management and use hand made gemspec.
18 s.post_install_message = "When you HTTParty, you must party hard!"
19
20 s.files = `git ls-files`.split("\n")
21 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
22 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
23 s.require_paths = ["lib"]
24 end
Something went wrong with that request. Please try again.