Skip to content
master
Switch branches/tags
Go to file
Code

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
 
 
 
 
lib
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

README.md

This is a universal Python binding for the LMDB ‘Lightning’ Database.

See the documentation for more information.

CI State

Build, run, and test py-lmdb

Python Version Support Statement

This project has been around for a while. Previously, it supported all the way back to before 2.5. Currently py-lmdb supports Python 2.7, Python >= 3.5, and pypy.

Python 2.7 is now end-of-life. If you are still using Python 2.7, you should strongly considering porting to Python 3.

That said, this project will continue to support running on Python 2.7 until Github Actions remove support for it.

Sponsored by The Vertex Project

My current employer, The Vertex Project is generously sponsoring my time to maintain py-lmdb. If you're a developer and you like open source and systems programming in Python, check us out. If you're an intelligence analyst, check out Vertex's Intelligence Analysis Platform, Synapse.