incompatibility with latest emacs snapshot (24.3.50.1) #339

Closed
joostkremers opened this Issue Nov 22, 2012 · 3 comments

Comments

Projects
None yet
2 participants

I just updated my Emacs install (I'm using Damien Cassou's Emacs snapshot packages for Ubuntu at https://launchpad.net/~cassou/+archive/emacs ) and now, when I start Emacs, yasnippet gives an error:

Eager macro-expansion failure: (wrong-type-argument subrp #[(&optional kind) "�

followed by what looks like gibberish, with lots of control characters (causing pasting it here to fail).

My yasnippet install is up-to-date (just pulled the latest commits).

Any idea what might be going on?

TIA

Going back one commit at a time, I found that the last commit that does not give the error is:

880767e Merge remote-tracking branch 'rolandwalker/flet'

The commit after that is 7d411fb

The following patch fixes the problem for me (against HEAD, i.e, cfefaca, obviously):

--- a/yasnippet.el
+++ b/yasnippet.el
@@ -1311,7 +1311,8 @@ them all in `yas--menu-table'"

 Optional KIND is as documented at `called-interactively-p'
 in GNU Emacs 24.1 or higher."
-  (if (eq 0 (cdr (subr-arity (symbol-function 'called-interactively-p))))
+  (if (string< "24.1" emacs-version)
       '(called-interactively-p)
     `(called-interactively-p ,kind)))

Although I haven't tested with Emacs < 24.3, I doubt it'll cause a problem.

Note that the doc string for subr-arity says that its argument should be a built-in function, which called-interactively-p is definitely not (it's defined in subr.el). So it probably shouldn't be used here.

Owner

joaotavora commented Nov 27, 2012

Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment