Skip to content
This repository
Browse code

Update dev dependencies and set hard Rails >= 3.1 in gemspec

Sorry, everyone on < Rails 3.1 :(

Rails::Engine is broken on 3.0 and can't be supported.
  • Loading branch information...
commit 05882ec96d918f1de8b3b1d7ca7c8d0097c48be0 1 parent b5821cf
Joe Corcoran authored
4 Appraisals
... ... @@ -1,7 +1,7 @@
1 1 appraise "rails_3_1" do
2   - gem "rails", "3.1.8"
  2 + gem "rails", "3.1.11"
3 3 end
4 4
5 5 appraise "rails_3_2" do
6   - gem "rails", "3.2.9"
  6 + gem "rails", "3.2.12"
7 7 end
2  gemfiles/rails_3_1.gemfile
@@ -2,6 +2,6 @@
2 2
3 3 source "http://rubygems.org"
4 4
5   -gem "rails", "3.1.8"
  5 +gem "rails", "3.1.11"
6 6
7 7 gemspec :path=>"../"
2  gemfiles/rails_3_2.gemfile
@@ -2,6 +2,6 @@
2 2
3 3 source "http://rubygems.org"
4 4
5   -gem "rails", "3.2.9"
  5 +gem "rails", "3.2.12"
6 6
7 7 gemspec :path=>"../"
37 judge.gemspec
... ... @@ -1,26 +1,23 @@
1   -$:.push File.expand_path("../lib", __FILE__)
  1 +$:.push File.expand_path('../lib', __FILE__)
2 2
3   -# Maintain your gem's version:
4   -require "judge/version"
  3 +require 'judge/version'
5 4
6   -# Describe your gem and declare its dependencies:
7 5 Gem::Specification.new do |s|
8   - s.name = "judge"
  6 + s.name = 'judge'
9 7 s.version = Judge::VERSION
10   - s.homepage = "http://github.com/joecorcoran/judge"
11   - s.summary = "Simple client side ActiveModel::Validators"
12   - s.description = "Validate Rails 3 forms on the client side, cleanly"
13   - s.email = "joecorcoran@gmail.com"
14   - s.authors = ["Joe Corcoran"]
  8 + s.homepage = 'http://github.com/joecorcoran/judge'
  9 + s.summary = 'Client side validation for Rails'
  10 + s.description = 'Validate Rails 3 forms on the client side, simply'
  11 + s.email = 'joecorcoran@gmail.com'
  12 + s.authors = ['Joe Corcoran']
  13 + s.files = Dir['{app,config,lib,vendor}/**/*'] + ['LICENSE.txt', 'README.md']
15 14
16   - s.files = Dir["{app,config,lib,vendor}/**/*"] + ["LICENSE.txt", "Rakefile", "README.md"]
  15 + s.add_runtime_dependency 'rails', '>= 3.1'
17 16
18   - s.add_development_dependency "sqlite3"
19   - s.add_development_dependency "jasmine", "~> 1.1.2"
20   - s.add_development_dependency "rails", "~> 3.1"
21   - s.add_development_dependency "rspec-rails", "~> 2.9"
22   - s.add_development_dependency "jquery-rails"
23   - s.add_development_dependency "sqlite3", "~> 1.3.5"
24   - s.add_development_dependency "factory_girl", "~> 2.6"
25   - s.add_development_dependency "appraisal", "~> 0.4.1"
26   -end
  17 + s.add_development_dependency 'jasmine', '~> 1.1.2'
  18 + s.add_development_dependency 'rspec-rails', '~> 2.13.0'
  19 + s.add_development_dependency 'jquery-rails'
  20 + s.add_development_dependency 'sqlite3', '~> 1.3.7'
  21 + s.add_development_dependency 'factory_girl', '~> 2.6'
  22 + s.add_development_dependency 'appraisal', '~> 0.5.1'
  23 +end

0 comments on commit 05882ec

Please sign in to comment.
Something went wrong with that request. Please try again.