Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Update dev dependencies and set hard Rails >= 3.1 in gemspec

Sorry, everyone on Rails 3.1 :( Rails::Engine is broken on 3.0.
  • Loading branch information...
commit b5c214d1ee69b37d796b0d3f700806897367428c 1 parent b5821cf
@joecorcoran authored
View
4 Appraisals
@@ -1,7 +1,7 @@
appraise "rails_3_1" do
- gem "rails", "3.1.8"
+ gem "rails", "3.1.11"
end
appraise "rails_3_2" do
- gem "rails", "3.2.9"
+ gem "rails", "3.2.12"
end
View
2  gemfiles/rails_3_1.gemfile
@@ -2,6 +2,6 @@
source "http://rubygems.org"
-gem "rails", "3.1.8"
+gem "rails", "3.1.11"
gemspec :path=>"../"
View
2  gemfiles/rails_3_2.gemfile
@@ -2,6 +2,6 @@
source "http://rubygems.org"
-gem "rails", "3.2.9"
+gem "rails", "3.2.12"
gemspec :path=>"../"
View
37 judge.gemspec
@@ -1,26 +1,23 @@
-$:.push File.expand_path("../lib", __FILE__)
+$:.push File.expand_path('../lib', __FILE__)
-# Maintain your gem's version:
-require "judge/version"
+require 'judge/version'
-# Describe your gem and declare its dependencies:
Gem::Specification.new do |s|
- s.name = "judge"
+ s.name = 'judge'
s.version = Judge::VERSION
- s.homepage = "http://github.com/joecorcoran/judge"
- s.summary = "Simple client side ActiveModel::Validators"
- s.description = "Validate Rails 3 forms on the client side, cleanly"
- s.email = "joecorcoran@gmail.com"
- s.authors = ["Joe Corcoran"]
+ s.homepage = 'http://github.com/joecorcoran/judge'
+ s.summary = 'Client side validation for Rails'
+ s.description = 'Validate Rails 3 forms on the client side, simply'
+ s.email = 'joecorcoran@gmail.com'
+ s.authors = ['Joe Corcoran']
+ s.files = Dir['{app,config,lib,vendor}/**/*'] + ['LICENSE.txt', 'README.md']
- s.files = Dir["{app,config,lib,vendor}/**/*"] + ["LICENSE.txt", "Rakefile", "README.md"]
+ s.add_runtime_dependency 'rails', '>= 3.1'
- s.add_development_dependency "sqlite3"
- s.add_development_dependency "jasmine", "~> 1.1.2"
- s.add_development_dependency "rails", "~> 3.1"
- s.add_development_dependency "rspec-rails", "~> 2.9"
- s.add_development_dependency "jquery-rails"
- s.add_development_dependency "sqlite3", "~> 1.3.5"
- s.add_development_dependency "factory_girl", "~> 2.6"
- s.add_development_dependency "appraisal", "~> 0.4.1"
-end
+ s.add_development_dependency 'jasmine', '~> 1.1.2'
+ s.add_development_dependency 'rspec-rails', '~> 2.13.0'
+ s.add_development_dependency 'jquery-rails'
+ s.add_development_dependency 'sqlite3', '~> 1.3.7'
+ s.add_development_dependency 'factory_girl', '~> 2.6'
+ s.add_development_dependency 'appraisal', '~> 0.5.1'
+end
Please sign in to comment.
Something went wrong with that request. Please try again.