Permalink
Browse files

fix install

  • Loading branch information...
1 parent d2295dd commit 9f1e9b10046524a904b4eef713032fdbed20eddf @joeferner committed Dec 20, 2016
Showing with 12 additions and 59 deletions.
  1. +0 −2 .npmignore
  2. +6 −1 README.md
  3. +2 −53 binding.gyp
  4. +3 −2 index.js
  5. +1 −1 package.json
View
@@ -4,6 +4,4 @@
pre_install_check.sh
.npmignore
INSTALL.md
-binding.gyp
tests-settings.json
-
View
@@ -1,3 +1,8 @@
-# This library is not maintained. Oracle has a [new oracledb driver](https://github.com/oracle/node-oracledb). Please install the new driver with 'npm install oracledb'
+# This library is not maintained.
+
+The node-oracle driver is obsolete. Oracle has a new
+driver: [node-oracledb](https://github.com/oracle/node-oracledb).
+
+Please install the new driver with 'npm install oracledb'. Instructions are [here](https://github.com/oracle/node-oracledb/blob/master/INSTALL.md).
If you absolutely need the old driver, use 'npm install oracle@0.3.9'
View
@@ -1,59 +1,8 @@
{
"targets": [
{
- "target_name": "oracle_bindings",
- "sources": [ "src/connection.cpp",
- "src/oracle_bindings.cpp",
- "src/executeBaton.cpp",
- "src/reader.cpp",
- "src/statement.cpp",
- "src/outParam.cpp" ],
- "conditions": [
- ["OS=='mac'", {
- "xcode_settings": {
- "GCC_ENABLE_CPP_EXCEPTIONS": "YES",
- "GCC_ENABLE_CPP_RTTI": "YES"
- }
- }],
- ["OS!='win'", {
- "variables": {
- "oci_include_dir%": "<!(if [ -z $OCI_INCLUDE_DIR ]; then echo \"/opt/instantclient/sdk/include/\"; else echo $OCI_INCLUDE_DIR; fi)",
- "oci_lib_dir%": "<!(if [ -z $OCI_LIB_DIR ]; then echo \"/opt/instantclient/\"; else echo $OCI_LIB_DIR; fi)",
- "oci_version%": "<!(if [ -z $OCI_VERSION ]; then echo 11; else echo $OCI_VERSION; fi)"
- },
- "libraries": [ "-locci", "-lclntsh", "-lnnz<(oci_version)" ],
- "link_settings": {"libraries": [ '-L<(oci_lib_dir)'] }
- }],
- ["OS=='win'", {
- "configurations": {
- "Release": {
- "msvs_settings": {
- "VCCLCompilerTool": {
- "RuntimeLibrary": "2"
- }
- },
- },
- "Debug": {
- "msvs_settings": {
- "VCCLCompilerTool": {
- "RuntimeLibrary": "3"
- }
- },
- }
- },
- "variables": {
- "oci_include_dir%": "<!(IF DEFINED OCI_INCLUDE_DIR (echo %OCI_INCLUDE_DIR%) ELSE (echo C:\oracle\instantclient\sdk\include))",
- "oci_lib_dir%": "<!(IF DEFINED OCI_LIB_DIR (echo %OCI_LIB_DIR%) ELSE (echo C:\oracle\instantclient\sdk\lib\msvc))",
- "oci_version%": "<!(IF DEFINED OCI_VERSION (echo %OCI_VERSION%) ELSE (echo 11))"
- },
- # "libraries": [ "-loci" ],
- "link_settings": {"libraries": [ '<(oci_lib_dir)\oraocci<(oci_version).lib'] }
- }]
- ],
- "include_dirs": [ "<(oci_include_dir)" ],
- "cflags!": [ "-fno-exceptions" ],
- "cflags_cc!": [ "-fno-exceptions" ]
- }
+ "target_name": "oracle_bindings"
+ }
]
}
View
@@ -1,3 +1,4 @@
-console.error("This library is not maintained. Oracle has made their own [driver](https://github.com/oracle/node-oracledb). Please install the new driver with 'npm install oracledb'");
-console.error("If you absolutely need the old driver, use 'npm install oracle@0.3.9'")
+console.error("This node-oracle driver is obsolete. Oracle has a new driver: https://github.com/oracle/node-oracledb.");
+console.error("Please install the new driver with 'npm install oracledb', see https://github.com/oracle/node-oracledb/blob/master/INSTALL.md");
+console.error("If you absolutely need the old driver, use 'npm install oracle@0.3.9'");
View
@@ -4,7 +4,7 @@
"keywords": ["database", "db", "oracle"],
"homepage": "https://github.com/joeferner/node-oracle",
"license": "MIT",
- "version": "0.4.0",
+ "version": "0.4.1",
"engines": {
"node": ">=0.6.0"
},

0 comments on commit 9f1e9b1

Please sign in to comment.