This repository has been archived by the owner. It is now read-only.

Installation on win7 failed: Sublime text plugin failed, unable reach github #113

Closed
ghost opened this Issue Oct 21, 2013 · 28 comments

Comments

Projects
None yet
9 participants
@ghost

ghost commented Oct 21, 2013

I installed github, sublime text and on Mavensmate installation at the end theres this error:

image

@joeferraro

This comment has been minimized.

Show comment
Hide comment
@joeferraro

joeferraro Oct 23, 2013

Owner

@Hassan1312 FYI

@SebasCanseco @Hassan1312 do you have a local firewall? Are you able to reach git via the command line? What happens when you run:

$ git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git ?

Owner

joeferraro commented Oct 23, 2013

@Hassan1312 FYI

@SebasCanseco @Hassan1312 do you have a local firewall? Are you able to reach git via the command line? What happens when you run:

$ git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git ?

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Oct 23, 2013

Sorry, Im new to git stuff.. where should I run that line? through windows cmd.exe?

ghost commented Oct 23, 2013

Sorry, Im new to git stuff.. where should I run that line? through windows cmd.exe?

@joeferraro

This comment has been minimized.

Show comment
Hide comment
@joeferraro

joeferraro Oct 23, 2013

Owner

yep (copy/paste/run without the $)

Owner

joeferraro commented Oct 23, 2013

yep (copy/paste/run without the $)

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Oct 23, 2013

I ran the line and I got this:
image

Then tried to resintall and got the same error:
image

ghost commented Oct 23, 2013

I ran the line and I got this:
image

Then tried to resintall and got the same error:
image

@joeferraro

This comment has been minimized.

Show comment
Hide comment
@joeferraro

joeferraro Oct 23, 2013

Owner

Run these commands one after the other:

git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git MavensMate
cd MavensMate
git checkout -b master origin/master
git submodule init
git submodule update

then let us know the output of those commands

Owner

joeferraro commented Oct 23, 2013

Run these commands one after the other:

git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git MavensMate
cd MavensMate
git checkout -b master origin/master
git submodule init
git submodule update

then let us know the output of those commands

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Oct 23, 2013

Running the first line:
git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git

from c:\program files\git\bin\ the response was:
fatal: destination path 'MavensMate-SublimeText' already exists and is not an empty directory

Should I delete that directory first?

ghost commented Oct 23, 2013

Running the first line:
git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git

from c:\program files\git\bin\ the response was:
fatal: destination path 'MavensMate-SublimeText' already exists and is not an empty directory

Should I delete that directory first?

@joeferraro

This comment has been minimized.

Show comment
Hide comment
@joeferraro

joeferraro Oct 23, 2013

Owner

@SebasCanseco yes delete that directory, then run those commands in order

Owner

joeferraro commented Oct 23, 2013

@SebasCanseco yes delete that directory, then run those commands in order

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Oct 23, 2013

Sorry dude, complete newbie here. This i what I did:

  1. deleted C:\Program Files\Git\bin\MavensMate-SublimeText

  2. cmd from C:\Program Files\Git\bin\git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git MavensMate

  3. I cd MavensMate (C:\Program Files\Git\bin\MavensMate-SublimeText) and tried to run
    git checkout -b master origin/master
    No luck since git.exe is not there.

  4. From bin I tried to run this:
    git checkout -b master origin/master
    Response was:
    fatal: Not a git repository (or any of the paren directories): .git

  5. From bin I tried to run this too:
    git checkout -b master origin/master --exec-path=C:\program files\git\bin\MavensMate-SublimeText
    Response was:
    fatal: Not a git repository (or any of the paren directories): .git

ghost commented Oct 23, 2013

Sorry dude, complete newbie here. This i what I did:

  1. deleted C:\Program Files\Git\bin\MavensMate-SublimeText

  2. cmd from C:\Program Files\Git\bin\git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git MavensMate

  3. I cd MavensMate (C:\Program Files\Git\bin\MavensMate-SublimeText) and tried to run
    git checkout -b master origin/master
    No luck since git.exe is not there.

  4. From bin I tried to run this:
    git checkout -b master origin/master
    Response was:
    fatal: Not a git repository (or any of the paren directories): .git

  5. From bin I tried to run this too:
    git checkout -b master origin/master --exec-path=C:\program files\git\bin\MavensMate-SublimeText
    Response was:
    fatal: Not a git repository (or any of the paren directories): .git

@Hassan1312

This comment has been minimized.

Show comment
Hide comment
@Hassan1312

Hassan1312 Oct 23, 2013

@joeferraro Thank you for pointing me here..Ill see how I go with the above instructions. I am currently on a proxy server at work so can't access te server trough command prompt..Ill try this later today when I get home. i get the below error when I run it from work after disabling my firewalls
error

Hassan1312 commented Oct 23, 2013

@joeferraro Thank you for pointing me here..Ill see how I go with the above instructions. I am currently on a proxy server at work so can't access te server trough command prompt..Ill try this later today when I get home. i get the below error when I run it from work after disabling my firewalls
error

@Hassan1312

This comment has been minimized.

Show comment
Hide comment
@Hassan1312

Hassan1312 Oct 23, 2013

@joeferraro I have just ran the mavensmate setup again and it seemed to have installed properly but when I open sublime text and try open a new project no login screen comes up for Force.com.

All I get is a processing message in the bottom toolbar of sublime text editor and then operation complete message.

Do you think I might need to install it again or has something gone wrong. I can't see the Mavens app running in my taskbar as well. I'm assuming Mavensmate would run in the background as well to establish connection with the Force.com server.

Regards
Hassan

Hassan1312 commented Oct 23, 2013

@joeferraro I have just ran the mavensmate setup again and it seemed to have installed properly but when I open sublime text and try open a new project no login screen comes up for Force.com.

All I get is a processing message in the bottom toolbar of sublime text editor and then operation complete message.

Do you think I might need to install it again or has something gone wrong. I can't see the Mavens app running in my taskbar as well. I'm assuming Mavensmate would run in the background as well to establish connection with the Force.com server.

Regards
Hassan

@Hassan1312

This comment has been minimized.

Show comment
Hide comment
@Hassan1312

Hassan1312 Oct 23, 2013

This what I see when I select new project from Mavensmate in sublime.

sublime

Hassan1312 commented Oct 23, 2013

This what I see when I select new project from Mavensmate in sublime.

sublime

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Oct 24, 2013

@joeferraro Hi, did you have time to check out the installation issue?

ghost commented Oct 24, 2013

@joeferraro Hi, did you have time to check out the installation issue?

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Oct 30, 2013

@joeferraro are you around? I really need mavensmate to install properly :(

ghost commented Oct 30, 2013

@joeferraro are you around? I really need mavensmate to install properly :(

@markotomictoma

This comment has been minimized.

Show comment
Hide comment
@markotomictoma

markotomictoma Dec 2, 2013

I have the same problem. I tried above commands and when I do:
git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git MavensMate
I get: Cloning into 'MavensMate'... and a lot of response after that including the progress of downloading the files. Looks to me that everything is ok here, files are there. Folders lib, mm, support, themes and bunch of files are also there.

After doing the cd MavensMate and doing:
git checkout -b master origin/master
I get: fatal: A branch named 'master' already exists

init and update goes without any response.

Hope this helps resolving this issue. I am here do try whatever it needs to help further.

Thank you

markotomictoma commented Dec 2, 2013

I have the same problem. I tried above commands and when I do:
git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git MavensMate
I get: Cloning into 'MavensMate'... and a lot of response after that including the progress of downloading the files. Looks to me that everything is ok here, files are there. Folders lib, mm, support, themes and bunch of files are also there.

After doing the cd MavensMate and doing:
git checkout -b master origin/master
I get: fatal: A branch named 'master' already exists

init and update goes without any response.

Hope this helps resolving this issue. I am here do try whatever it needs to help further.

Thank you

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Dec 2, 2013

I ended up formatting my computer and then I was able to make it work

ghost commented Dec 2, 2013

I ended up formatting my computer and then I was able to make it work

@moevin

This comment has been minimized.

Show comment
Hide comment
@moevin

moevin Jan 13, 2014

I'm having the same problem tdusko is having.
git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git MavensMate
seems to work great but when I switch folder to MavensMate and
git checkout -b master origin/master
It tells me that a branch named master already exists.

Any help here would be fantastic!

moevin commented Jan 13, 2014

I'm having the same problem tdusko is having.
git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git MavensMate
seems to work great but when I switch folder to MavensMate and
git checkout -b master origin/master
It tells me that a branch named master already exists.

Any help here would be fantastic!

@joeferraro

This comment has been minimized.

Show comment
Hide comment
@joeferraro

joeferraro Jan 13, 2014

Owner

that should be ok, run the next two commands:

git submodule init
git submodule update
Owner

joeferraro commented Jan 13, 2014

that should be ok, run the next two commands:

git submodule init
git submodule update
@moevin

This comment has been minimized.

Show comment
Hide comment
@moevin

moevin Jan 13, 2014

Those both complete successfully without output. I had a buddy here at work help me with the rest (as sublime still wasn't showing the MavensMate tab)... For those of you doing this, the folder you installed the MavensMate package in is important, so it has to be moved to be added to sublime. If you cut the MavensMate folder you just created and paste it into the folder you find when you go to preferences->browse packages then your MavensMate tab will show up and you can create a project. But be sure to complete the step where you set your mm_workspace....

moevin commented Jan 13, 2014

Those both complete successfully without output. I had a buddy here at work help me with the rest (as sublime still wasn't showing the MavensMate tab)... For those of you doing this, the folder you installed the MavensMate package in is important, so it has to be moved to be added to sublime. If you cut the MavensMate folder you just created and paste it into the folder you find when you go to preferences->browse packages then your MavensMate tab will show up and you can create a project. But be sure to complete the step where you set your mm_workspace....

@moevin

This comment has been minimized.

Show comment
Hide comment
@moevin

moevin Jan 13, 2014

Thank you Joe for your help!!

moevin commented Jan 13, 2014

Thank you Joe for your help!!

@victorabraham

This comment has been minimized.

Show comment
Hide comment
@victorabraham

victorabraham Feb 14, 2014

I have cut and paste MavensMate folder to preferences->browse folder. Now it is showing up in Sublime. But all options under MavensMate->Projects-> are disabled(like Open Project, New Project etc)

Please help.

victorabraham commented Feb 14, 2014

I have cut and paste MavensMate folder to preferences->browse folder. Now it is showing up in Sublime. But all options under MavensMate->Projects-> are disabled(like Open Project, New Project etc)

Please help.

@joeferraro

This comment has been minimized.

Show comment
Hide comment
@joeferraro

joeferraro Feb 23, 2014

Owner

For those having issues installing on Windows who are NOT behind a proxy or have their proxy setup properly:

Certain versions of git seem to trip over a line in the current install script. This dev build of the installer catches that exception more gracefully. If this build of the installer does not work for you, it's likely you have a firewall/proxy issue. Let us know whether this version of the installer works for you.

https://www.dropbox.com/s/6b6u2pztafpqfe0/MavensMate.exe

Owner

joeferraro commented Feb 23, 2014

For those having issues installing on Windows who are NOT behind a proxy or have their proxy setup properly:

Certain versions of git seem to trip over a line in the current install script. This dev build of the installer catches that exception more gracefully. If this build of the installer does not work for you, it's likely you have a firewall/proxy issue. Let us know whether this version of the installer works for you.

https://www.dropbox.com/s/6b6u2pztafpqfe0/MavensMate.exe

@itkevin

This comment has been minimized.

Show comment
Hide comment
@itkevin

itkevin Feb 26, 2014

Just tried the DropBox version behind a working Proxy config. It works without an Error.

itkevin commented Feb 26, 2014

Just tried the DropBox version behind a working Proxy config. It works without an Error.

@jupitersspot

This comment has been minimized.

Show comment
Hide comment
@jupitersspot

jupitersspot Apr 2, 2014

I think it might be a nice addition to the installer to check for the presence of git. If the installer were to check for git as a first step, it could avoid extracting files for an installation that will always fail, and you could present a meaningful message like "MavensMate installation requires git. Go to to install git". I know that there's a static text message on the installer, but the average Joe doesn't read the static text on the installer screen anymore.

I also have challenges with this installation. I have installed git, Chrome, and Sublime and both the Win 7 installer from the MavensMate site and the DropBox version fail for me with the same error as original poster. When I attempt to run from command line
git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git MavensMate
I see retrieval from repositories, but then a series of messages of the form "unable to create file in lib/ui/resources/editor/mode-xxxx.js (Permission denied)"

Question: from what directory did you intend that the git command be run from? Installing git seems not to put git in the path, so it seems you must run it from c:\program files (x86)\git\bin, but this places the MavensMate stuff retrieved by git into the git directory structure.

jupitersspot commented Apr 2, 2014

I think it might be a nice addition to the installer to check for the presence of git. If the installer were to check for git as a first step, it could avoid extracting files for an installation that will always fail, and you could present a meaningful message like "MavensMate installation requires git. Go to to install git". I know that there's a static text message on the installer, but the average Joe doesn't read the static text on the installer screen anymore.

I also have challenges with this installation. I have installed git, Chrome, and Sublime and both the Win 7 installer from the MavensMate site and the DropBox version fail for me with the same error as original poster. When I attempt to run from command line
git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git MavensMate
I see retrieval from repositories, but then a series of messages of the form "unable to create file in lib/ui/resources/editor/mode-xxxx.js (Permission denied)"

Question: from what directory did you intend that the git command be run from? Installing git seems not to put git in the path, so it seems you must run it from c:\program files (x86)\git\bin, but this places the MavensMate stuff retrieved by git into the git directory structure.

@jupitersspot

This comment has been minimized.

Show comment
Hide comment
@jupitersspot

jupitersspot Apr 2, 2014

I was able to install by navigating to the MavensMate target (c:\program files (x86)\MavensMate) and running MavensMate-SublimeText.exe by hand.

It would also be kind to be explicit about the syntax of the mm_settings. I used:

{
"mm_workspace" : "C:\Users\David\Documents\Projects"
}

jupitersspot commented Apr 2, 2014

I was able to install by navigating to the MavensMate target (c:\program files (x86)\MavensMate) and running MavensMate-SublimeText.exe by hand.

It would also be kind to be explicit about the syntax of the mm_settings. I used:

{
"mm_workspace" : "C:\Users\David\Documents\Projects"
}

@jupitersspot

This comment has been minimized.

Show comment
Hide comment
@jupitersspot

jupitersspot Apr 3, 2014

I installed on another machine and this time I got a full copy of the MavensMate settings file, that made clear the syntax for the mm_settings. I'm sure it was user error that caused this file not to appear on my first attempt.

jupitersspot commented Apr 3, 2014

I installed on another machine and this time I got a full copy of the MavensMate settings file, that made clear the syntax for the mm_settings. I'm sure it was user error that caused this file not to appear on my first attempt.

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost May 22, 2014

This link has been very helpful installing mavensmate in windows: http://techman97.wordpress.com/2014/03/11/installing-mavensmate-on-win7-64bit/

ghost commented May 22, 2014

This link has been very helpful installing mavensmate in windows: http://techman97.wordpress.com/2014/03/11/installing-mavensmate-on-win7-64bit/

@joeferraro joeferraro closed this Aug 18, 2014

@sivasivadasan

This comment has been minimized.

Show comment
Hide comment
@sivasivadasan

sivasivadasan Nov 20, 2014

Hello All :)
Have a good day!
Simple steps to washout the error!
I have faced same error in few machines...

1.Uninstall gitscm tool COMPLETELY,
2.Use CCleaner to clean the history
3.Restart the machine
4.Install the latest version of both gitscm ( http://git-scm.com/ ) and github ( https://github.com/ )
5.Again restart the machine
6. Confirm the Git installation through command prompt
7.Install the sublime text editor and close it
8.Install the mavensmate app
9.Open the sublime text app wait five mins it will fetch the latest MavensMate Api otherwise manually update the MavensMate Api and restart the sublime text.
10.Configure the workspace
11. Use Chrome as default browsers!
Thats all !!! Happy Coding!!!

sivasivadasan commented Nov 20, 2014

Hello All :)
Have a good day!
Simple steps to washout the error!
I have faced same error in few machines...

1.Uninstall gitscm tool COMPLETELY,
2.Use CCleaner to clean the history
3.Restart the machine
4.Install the latest version of both gitscm ( http://git-scm.com/ ) and github ( https://github.com/ )
5.Again restart the machine
6. Confirm the Git installation through command prompt
7.Install the sublime text editor and close it
8.Install the mavensmate app
9.Open the sublime text app wait five mins it will fetch the latest MavensMate Api otherwise manually update the MavensMate Api and restart the sublime text.
10.Configure the workspace
11. Use Chrome as default browsers!
Thats all !!! Happy Coding!!!

@raJSN

This comment has been minimized.

Show comment
Hide comment
@raJSN

raJSN Mar 19, 2015

I got the same error. Solution was simple.

  1. Set GIT in your system environment variable "Path".
  2. Check GIT command in CMD.
  3. If GIT exists as command, install mavensmate.

It worked for me.

raJSN commented Mar 19, 2015

I got the same error. Solution was simple.

  1. Set GIT in your system environment variable "Path".
  2. Check GIT command in CMD.
  3. If GIT exists as command, install mavensmate.

It worked for me.

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.