FAQ

Joe Fitzgerald edited this page Jan 6, 2017 · 8 revisions

Autocomplete (gocode)

Help! The only autocomplete suggestion that I am receiving is PANIC...

When you upgrade the version of go that you are using, you may also need to update gocode and re-create the gocode binary. Run gocode close && go get -u github.com/nsf/gocode and then resume typing in Atom.

This is automatically run as part of the golang:update-tools command, which you can invoke via the command pallete, the Packages > go-plus menu, or keyboard shortcut (ctrl + alt + shift + g  u).

go-plus will also try to detect this scenario and offer to close and update gocode for you. If this does not resolve the problem, you should look for open issues at https://github.com/nsf/gocode/issues, and optionally open a new issue if none of the open issues match your scenario.

Tools

I'm having an issue with one of the tools that go-plus uses

Prior to filing an issue, please ensure you are running the latest version of the tools. You can do this by doing one of the following things: