Skip to content
Find file
Fetching contributors…
Cannot retrieve contributors at this time
41 lines (34 sloc) 1.02 KB
source ''
require File.expand_path('../spec/support/detect_rails_version', __FILE__)
rails_version = ENV['RAILS'] || detect_rails_version || "3.1.0"
gem 'rails', rails_version
case rails_version
when /^3\.0/
# Do nothing, bundler should figure it out
when /^3\.1/
# These are the gems you have to have for Rails 3.1 to be happy
gem 'sass-rails'
gem 'uglifier'
raise "Rails #{rails_version} is not supported yet"
group :development, :test do
gem 'sqlite3-ruby', :require => 'sqlite3'
gem 'rake', '0.8.7', :require => false
gem 'haml', '~> 3.1.1', :require => false
gem 'yard'
gem 'rdiscount' # For yard
group :test do
gem 'rspec', '~> 2.6.0'
gem 'rspec-rails', '~> 2.6.0'
gem 'capybara', '1.0.0'
gem 'cucumber', '0.10.6'
gem 'cucumber-rails', '0.5.2'
gem 'database_cleaner'
gem 'shoulda', '2.11.2', :require => nil
gem 'launchy'
gem 'jslint_on_rails', '~> 1.0.6'
gem 'guard-rspec'
Jump to Line
Something went wrong with that request. Please try again.