New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Window mapping bug #114

Closed
Eszartek opened this Issue May 5, 2014 · 1 comment

Comments

Projects
None yet
2 participants
@Eszartek

Eszartek commented May 5, 2014

Using LXDE I found that if I repeatedly click the taskbar "show desktop" icon, all the currently mapped windows will unmap/map for a few clicks. But then after 10 or so clicks, all the mapped windows will loose their decoration/titlebar. If I open a new window at this point, it maps fine with the jwm titlebar and decorations, so jwm is not crashing/exiting. Running jwm -restart in a new xterm gets everything mapped correctly.

I'll try debugging later, Im thinking it has to do with getting a map all windows request while its in the middle of unmapping them all, or vise-versa.

Tested s913 and v2.2.0

@joewing joewing added the bug label May 16, 2014

@joewing joewing added this to the Version 2.2.3 milestone May 16, 2014

@joewing

This comment has been minimized.

Show comment
Hide comment
@joewing

joewing May 16, 2014

Owner

This should be fixed in snapshot 927.
Thanks!

Owner

joewing commented May 16, 2014

This should be fixed in snapshot 927.
Thanks!

@joewing joewing closed this May 16, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment