Permalink
Browse files

Move install_requires to requirements.txt

  • Loading branch information...
1 parent 1f391ca commit 1ff9d9592d2c1c4e5f5c08d7e0bb91ceb3d15624 @joeyespo committed Nov 21, 2012
Showing with 10 additions and 5 deletions.
  1. +3 −0 requirements.txt
  2. +7 −5 setup.py
View
@@ -0,0 +1,3 @@
+flask>=0.9
+jinja2>=2.6
+requests>=0.14
View
@@ -26,6 +26,12 @@
import grip as package
+def read(fname):
+ import os
+ with open(os.path.join(os.path.dirname(__file__), fname)) as f:
+ return f.read()
+
+
setup(
name=package.__name__,
author='Joe Esposito',
@@ -39,9 +45,5 @@
packages=find_packages(),
package_data={package.__name__: ['LICENSE', 'static/*', 'templates/*']},
entry_points={'console_scripts': ['grip = grip.command:main']},
- install_requires=[
- 'flask>=0.9',
- 'jinja2>=2.6',
- 'requests>=0.14',
- ],
+ install_requires=read('requirements.txt'),
)

0 comments on commit 1ff9d95

Please sign in to comment.