Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Qt 4.8 fix #177

Merged
merged 1 commit into from

2 participants

@jeremy-brenner

Just a compiler directive to include getopt.h when qt version > 4.8. Fixes specrunner compile issues on newer qt versions:

specrunner.cpp: In function ‘int main(int, char*)’:
specrunner.cpp:37:39: error: ‘getopt’ was not declared in this scope
specrunner.cpp:43:20: error: ‘optarg’ was not declared in this scope
specrunner.cpp:48:7: error: ‘optind’ was not declared in this scope
specrunner.cpp:61:16: error: ‘optind’ was not declared in this scope
make: *
* [specrunner.o] Error 1

If you could merge it would be superfantastic.

@jeremy-brenner

P.S. This doesn't break builds on qt 4.7

@johnbintz johnbintz merged commit 1055dc1 into johnbintz:master
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
This page is out of date. Refresh to see the latest.
Showing with 4 additions and 0 deletions.
  1. +4 −0 ext/jasmine-webkit-specrunner/specrunner.cpp
View
4 ext/jasmine-webkit-specrunner/specrunner.cpp
@@ -23,6 +23,10 @@
#include "Runner.h"
+#if QT_VERSION >= QT_VERSION_CHECK(4, 8, 0)
+#include <getopt.h>
+#endif
+
#if QT_VERSION < QT_VERSION_CHECK(4, 7, 0)
#error Use Qt 4.7 or later version
#endif
Something went wrong with that request. Please try again.