John Timms johngtimms

  • Joined on
@johngtimms
@johngtimms
@johngtimms
@johngtimms
@johngtimms
johngtimms commented on issue excon/excon#473
@johngtimms

@clarkdave I'm not the developer, but could you report the output of the following in irb? require 'openssl' puts OpenSSL::X509::DEFAULT_CERT_FILE …

johngtimms commented on issue excon/excon#473
@johngtimms

OK, here we go. On Windows: puts OpenSSL::X509::DEFAULT_CERT_DIR => C:/Users/Luis/Code/luislavena/knap-build/var/knapsack/software/x64-windows/open…

johngtimms commented on issue excon/excon#473
@johngtimms

Hmm, I thought we might be getting somewhere, but I don't believe this is it. On Windows: puts OpenSSL::X509::DEFAULT_CERT_FILE => C:/Users/Luis/Co…

johngtimms commented on issue excon/excon#473
@johngtimms

I'm not terribly familiar with how openssl works on Windows. I ran ruby -ropenssl -e 'puts OpenSSL::OPENSSL_VERSION' and got OpenSSL 1.0.0o 15 Oct …

johngtimms commented on issue excon/excon#473
@johngtimms

Nope, no proxy.

@johngtimms
@johngtimms
johngtimms commented on issue excon/excon#473
@johngtimms

On Windows: puts Excon.defaults[:ssl_ca_path].inspect => nil puts ENV['SSL_CERT_DIR'].inspect => nil puts Excon.defaults[:ssl_ca_file].inspect => n…

johngtimms commented on issue excon/excon#473
@johngtimms

No. I tested all of the variables/defaults listed in the error, none of them are set. I'm not experienced in Ruby debugging, but I made a short script

johngtimms commented on issue excon/excon#473
@johngtimms

Hi. I am experiencing the same issue on Windows 7, so hopefully I can provide some specifics. I have a team of people working on a Rails project an…