Skip to content
This repository

Spectre Graphics Engine for Dart

branch: master
README.md

Spectre

Build Status

A modern graphics API for WebGL development with Dart

Spectre is a modern graphics API aimed at developers creating games and other interactive 3D applications. It is designed for performance while retaining a developer friendly interface.

Try It Now

Spectre is in a fully working state, but the API has not completely solidified and is subject to change. This will be the case until an official 1.0 release occurs, though as this approaches major revisions are unlikely. Because of this it is recommended to work against the master branch of the library. It is also recommended to have the latest released version of the Dart SDK before starting development.

Add the Spectre package to your pubspec.yaml file which references the main repository.

dependencies:
  spectre:
    git: https://github.com/johnmccutchan/spectre.git

Then within your application it can be imported using the following code

import 'package:spectre/spectre.dart';

Documentation

API Reference

Something went wrong with that request. Please try again.