Manifest is not created in resulting JAR. #58

Closed
Minecrell opened this Issue Jun 27, 2014 · 2 comments

Comments

Projects
None yet
2 participants
@Minecrell
Contributor

Minecrell commented Jun 27, 2014

I have applied the application plugin to my build script and set the mainClassName correctly, however as of version 1.0.0 the manifest is not created at all. So there is only an empty META-INF folder in the resulting JAR file.
Also, if I try to run the generated JAR it tells me the following:

Error: Invalid or corrupt jarfile GradleTest-1.0-all.jar

I don't know if this is caused by the missing manifest or something else. Maybe I just configured the plugin wrong?
https://github.com/Minecrell/GradleTest

@johnrengelman

This comment has been minimized.

Show comment
Hide comment
@johnrengelman

johnrengelman Jun 27, 2014

Owner

Looks like it's a bug in the relocation code. As soon as relocation is applied, the MANIFEST.MF file does not show up.

Owner

johnrengelman commented Jun 27, 2014

Looks like it's a bug in the relocation code. As soon as relocation is applied, the MANIFEST.MF file does not show up.

@johnrengelman johnrengelman modified the milestones: 1.0.0, 1.0.1 Jun 27, 2014

@Minecrell

This comment has been minimized.

Show comment
Hide comment
@Minecrell

Minecrell Jun 28, 2014

Contributor

Yes, working for me in the latest version, thank you for the fix.

Contributor

Minecrell commented Jun 28, 2014

Yes, working for me in the latest version, thank you for the fix.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment