Skip to content
master
Go to file
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

README.md

gulp-rev-rails-manifest

Build Status

Write gulp-rev manifest.json that is Rails assets helper compatible

Install

$ npm install --save-dev gulp-rev-rails-manifest

Usage

var gulp = require('gulp');
var rev = require('gulp-rev');
var manifest = require('gulp-rev-rails-manifest');

gulp.task('default', function () {
    return gulp.src(['assets/css/*.css', 'assets/js/*.js'], {base: 'assets'})
        .pipe(rev())
        .pipe(gulp.dest('build/assets'))  // write rev'd assets to build dir
        .pipe(manifest())
        .pipe(gulp.dest('build/assets')); // write manifest to build dir
});

About

Write gulp-rev manifest.json that is Rails assets helper compatible

Resources

License

Releases

No releases published
You can’t perform that action at this time.