Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Trying to install - Hangs after answering "Perform environment setup (recommended?" #51

Closed
NeoMatrixJR opened this issue Oct 18, 2018 · 6 comments

Comments

Projects
None yet
6 participants
@NeoMatrixJR
Copy link

commented Oct 18, 2018

I'm trying to set this up but it just hangs after answering this...either yes or no.

@jmmoser

This comment has been minimized.

Copy link

commented Oct 19, 2018

@NeoMatrixJR I experienced the same issue running Node v10.12.0 on Windows Server 2016. The pm2-service-install command worked after downgrading to Node v8.12.0.

@markthewolf90

This comment has been minimized.

Copy link

commented Oct 23, 2018

@jmmoser That fixed it for me too.

@NeoMatrixJR

This comment has been minimized.

Copy link
Author

commented Oct 26, 2018

That got it, thanks!

@tbadlov

This comment has been minimized.

Copy link

commented Nov 28, 2018

Are there any plans to correct this to use the LTS version of Node?

@Noderino

This comment has been minimized.

Copy link

commented Dec 4, 2018

I think it is because of old Inquirer version. After upgrading it to 5.0 or newer solved the problem for me.

@aimerib

This comment has been minimized.

Copy link

commented Dec 4, 2018

I think it is because of old Inquirer version. After upgrading it to 5.0 or newer solved the problem for me.

You were spot on! Upgrading inquirer to newest version fixed this for me.

Updating the dependency for a module was new territory to me. I cannot recommend this method to anyone else struggling with the same issue, but what I did to get it going was:

npm install -g npm-check-updates

cd %USERPROFILE%\AppData\Roaming\npm\node_modules\pm2-windows-service
ncu inquirer -u
npm install

I ended up piecing this together from reading this article: https://flaviocopes.com/update-npm-dependencies/
and further reading the npm page for npm-check-updates: https://www.npmjs.com/package/npm-check-updates

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.