Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

The return_code is always a non 0 value #98

Closed
luisdavim opened this issue Jul 17, 2019 · 1 comment

Comments

@luisdavim
Copy link
Contributor

commented Jul 17, 2019

the last commit 623fe07 makes _kube_ps1_update_cache always return a non 0 value because it gets it's value from [[ "${KUBE_PS1_ENABLED}" == "off" ]] && return. I have my prompt configured to show a little icon that turns red when the last command exited with a value different from 0 and now it's constantly red because of this. the line local return_code=$? should be moved to be the very first line in the function.

luisdavim added a commit to luisdavim/kube-ps1 that referenced this issue Jul 17, 2019

luisdavim added a commit to luisdavim/kube-ps1 that referenced this issue Jul 17, 2019

@luisdavim

This comment has been minimized.

Copy link
Contributor Author

commented Jul 17, 2019

Opened a PR to fix it. #99

@luisdavim luisdavim referenced this issue Jul 17, 2019

@jonmosco jonmosco closed this in #99 Jul 17, 2019

jonmosco added a commit that referenced this issue Jul 17, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.