Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[com_fields] User custom field does display only when editing user #13601

Open
infograf768 opened this Issue Jan 15, 2017 · 17 comments

Comments

7 participants
@infograf768
Copy link
Member

infograf768 commented Jan 15, 2017

Steps to reproduce the issue

Create a User custom field.
Then when editing the user in back-end, a new tab is present with the new field. (122 here is the user id)
index.php?option=com_users&view=user&layout=edit&id=122
screen shot 2017-01-15 at 17 51 52

That is fine. Frontend is also fine.

Now edit your own profile in backend (Edit Account menu item top right)
index.php?option=com_admin&view=profile&layout=edit&id=122

Expected result

The new tab and Custom field should display. At least it is my expectation.

Actual result

It does not display.
screen shot 2017-01-15 at 17 54 38

@Bakual
@laoneo

What do you think?

@Bakual

This comment has been minimized.

Copy link
Contributor

Bakual commented Jan 15, 2017

Confirming the bug.
Profile edit works in frontend but not in backend.

@laoneo

This comment has been minimized.

Copy link
Member

laoneo commented Jan 16, 2017

Is there any reason why this view is loaded by com_admin and not com_users? That's the issue here as we are editing a user in a different component, so the events are loaded with a totally different context.

@Bakual

This comment has been minimized.

Copy link
Contributor

Bakual commented Jan 16, 2017

Wow, didn't even notice that.
Imho, that should move to com_users. The model already extends from a user model anyway.

@laoneo

This comment has been minimized.

Copy link
Member

laoneo commented Jan 16, 2017

I can create a pr, so it would be ok for the 3 series to move it to com_users, no BC issue here?

@Bakual

This comment has been minimized.

Copy link
Contributor

Bakual commented Jan 16, 2017

Theoretically there are no B/C issues, practically there most likely will be.
I would copy the code from com_admin to com_users, change the links but still leave the profile view working (but deprecated) in com_admin as well. Possibly by extending the new classes in com_users to avoid duplicate code where possible.

@laoneo

This comment has been minimized.

Copy link
Member

laoneo commented Jan 17, 2017

Same issue as here #5162 (thanks brian teeman for the hint).

@laoneo

This comment has been minimized.

Copy link
Member

laoneo commented Jan 24, 2017

So we are not the first ones with this issue. Looks like nikolas has it investigated extensively. If we can leave it as it is would be nice as I'm basically running out of time to do it.

@Bakual

This comment has been minimized.

Copy link
Contributor

Bakual commented Jan 24, 2017

I'd leave the issue open but it is certainly not a release blocker and could be done later.

@AlexRed

This comment has been minimized.

Copy link
Contributor

AlexRed commented May 2, 2017

I can confirm the problem on Joomla! 3.7.1-dev (nightly Build)

@brianteeman

This comment has been minimized.

Copy link
Contributor

brianteeman commented May 2, 2017

@AlexRed as this is still open then of course nothing has magically changed

@rdeutz

This comment has been minimized.

Copy link
Contributor

rdeutz commented May 7, 2017

This problem will not be fixed in 3.7.1.

@brianteeman

This comment has been minimized.

Copy link
Contributor

brianteeman commented Oct 4, 2017

@laoneo I am guessing that this is because the context is not correct. Those fields are for
context="com_users.user"

@laoneo

This comment has been minimized.

Copy link
Member

laoneo commented Oct 5, 2017

Yes exactly.

@rdeutz rdeutz removed their assignment Oct 5, 2017

@brianteeman

This comment has been minimized.

Copy link
Contributor

brianteeman commented Apr 10, 2018

pinging @laoneo

Really no need for this to stay open forever

@laoneo

This comment has been minimized.

Copy link
Member

laoneo commented Apr 10, 2018

We will address this issue in the Enhance User GsoC 2018 project. Please leave it open.

@laoneo laoneo self-assigned this Apr 10, 2018

@brianteeman

This comment has been minimized.

Copy link
Contributor

brianteeman commented Aug 18, 2018

@laoneo As far as I can see this has not been addressed in the GSOC project?

@laoneo

This comment has been minimized.

Copy link
Member

laoneo commented Aug 18, 2018

No as we didn't came that far as it was planed.

@brianteeman brianteeman added this to To do in [3.*] Fields via automation Aug 18, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.