New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Joomla is not installing on remote databases #17248

Merged
merged 5 commits into from Aug 2, 2017

Conversation

Projects
None yet
@zero-24
Contributor

zero-24 commented Jul 26, 2017

Pull Request for Issue #17246

Summary of Changes

I have just added a extra code that sets a session state when all checks passed. When this is set no thing is displayed.

For some reason that i did not come behind until now the installer did not run when there is any kind of message displayed.

Testing Instructions

try to install with a remote database
Zip package: https://github.com/zero-24/joomla-cms/archive/fixinstaller.zip

Expected result

works

Actual result

hangs at the installstep

Documentation Changes Required

This page should be updated with texts how to fix the 3.7.4 issue until this fix is delivered. https://docs.joomla.org/Special:MyLanguage/J3.x:Secured_procedure_for_installing_Joomla_with_a_remote_database

@AlexRed

This comment has been minimized.

Show comment
Hide comment
@AlexRed

AlexRed Jul 27, 2017

Contributor

Test ok for me on remote database with the fixinstaller.zip Joomla 3.8 version.

But after delete the txt file and press "next" in the installation procedure I can see again the message:

Warning
You are trying to use a database host which is not on your local server. For security reasons, you need to verify the ownership of your web hosting account. Please read the documentation for more information.

warning-fix

Better a "confirmation message" or nothing like if I try again with the same browser, no more checks.

Contributor

AlexRed commented Jul 27, 2017

Test ok for me on remote database with the fixinstaller.zip Joomla 3.8 version.

But after delete the txt file and press "next" in the installation procedure I can see again the message:

Warning
You are trying to use a database host which is not on your local server. For security reasons, you need to verify the ownership of your web hosting account. Please read the documentation for more information.

warning-fix

Better a "confirmation message" or nothing like if I try again with the same browser, no more checks.

@zero-24

This comment has been minimized.

Show comment
Hide comment
@zero-24

zero-24 Jul 27, 2017

Contributor

Yes because this is the message we displayed on the other sceen.
If you hit install the message is gone.

But i have something in mind that may can help here when i'm back to my PC later i can take a look if that works too.

Thanks.

Contributor

zero-24 commented Jul 27, 2017

Yes because this is the message we displayed on the other sceen.
If you hit install the message is gone.

But i have something in mind that may can help here when i'm back to my PC later i can take a look if that works too.

Thanks.

@Song2017

This comment has been minimized.

Show comment
Hide comment
@Song2017

Song2017 Jul 28, 2017

It seems that host like 127.0.0.1:49858 is not regarded as local database.
After delete verify file, it hangs on creating configuration File during Installing, then Got this

The most recent request was denied because it contained an invalid security token. 
Please refresh the page and try again.

Song2017 commented Jul 28, 2017

It seems that host like 127.0.0.1:49858 is not regarded as local database.
After delete verify file, it hangs on creating configuration File during Installing, then Got this

The most recent request was denied because it contained an invalid security token. 
Please refresh the page and try again.
@zero-24

This comment has been minimized.

Show comment
Hide comment
@zero-24

zero-24 Jul 28, 2017

Contributor

There is a dedicated PR for the ports thing: #17251

Contributor

zero-24 commented Jul 28, 2017

There is a dedicated PR for the ports thing: #17251

@zero-24

This comment has been minimized.

Show comment
Hide comment
@zero-24

zero-24 Jul 28, 2017

Contributor

@AlexRed please test again. Sorry that it took longer than expected..

Contributor

zero-24 commented Jul 28, 2017

@AlexRed please test again. Sorry that it took longer than expected..

@wilsonge

This comment has been minimized.

Show comment
Hide comment
@wilsonge

wilsonge Jul 31, 2017

Contributor

@zero-24 can you look at conflicts please?

Contributor

wilsonge commented Jul 31, 2017

@zero-24 can you look at conflicts please?

@zero-24

This comment has been minimized.

Show comment
Hide comment
@zero-24

zero-24 Jul 31, 2017

Contributor

fixed @wilsonge

Contributor

zero-24 commented Jul 31, 2017

fixed @wilsonge

@AlexRed

This comment has been minimized.

Show comment
Hide comment
@AlexRed

AlexRed Aug 2, 2017

Contributor

I have tested this item successfully on 3fe3e3f

Patch ok for me


This comment was created with the J!Tracker Application at issues.joomla.org/tracker/joomla-cms/17248.

Contributor

AlexRed commented Aug 2, 2017

I have tested this item successfully on 3fe3e3f

Patch ok for me


This comment was created with the J!Tracker Application at issues.joomla.org/tracker/joomla-cms/17248.

@e-struct

This comment has been minimized.

Show comment
Hide comment
@e-struct

e-struct Aug 2, 2017

Patch worked for me too.

e-struct commented Aug 2, 2017

Patch worked for me too.

@joomla-cms-bot joomla-cms-bot removed this from the Joomla 3.8.0 milestone Aug 2, 2017

@franz-wohlkoenig

This comment has been minimized.

Show comment
Hide comment
@franz-wohlkoenig

franz-wohlkoenig Aug 2, 2017

RTC after two successful tests.

franz-wohlkoenig commented Aug 2, 2017

RTC after two successful tests.

@joomla-cms-bot joomla-cms-bot added the RTC label Aug 2, 2017

@franz-wohlkoenig

This comment has been minimized.

Show comment
Hide comment
@franz-wohlkoenig

franz-wohlkoenig Aug 2, 2017

@e-struct i altered your Test as successfully at Issue Tracker. thanks for Test.

franz-wohlkoenig commented Aug 2, 2017

@e-struct i altered your Test as successfully at Issue Tracker. thanks for Test.

@mbabker mbabker merged commit cc2db64 into joomla:staging Aug 2, 2017

5 of 6 checks passed

continuous-integration/jenkins/pr-merge This commit is being built
Details
JTracker/HumanTestResults Human Test Results: 2 Successful 0 Failed.
Details
continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/drone/pr the build was successful
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
hound No violations found. Woof!

@joomla-cms-bot joomla-cms-bot removed the RTC label Aug 2, 2017

@mbabker mbabker added this to the Joomla 3.8.0 milestone Aug 2, 2017

@zero-24 zero-24 deleted the zero-24:fixinstaller branch Aug 2, 2017

@zero-24

This comment has been minimized.

Show comment
Hide comment
@zero-24

zero-24 Aug 2, 2017

Contributor

Thanks!

Contributor

zero-24 commented Aug 2, 2017

Thanks!

@Scorptech

This comment has been minimized.

Show comment
Hide comment
@Scorptech

Scorptech Aug 3, 2017

I'm not sure what this comment is trying to tell us? Do we remove this code in this file to get 3.7.4 to work?

Scorptech commented on 3fe3e3f Aug 3, 2017

I'm not sure what this comment is trying to tell us? Do we remove this code in this file to get 3.7.4 to work?

This comment has been minimized.

Show comment
Hide comment
@zero-24

zero-24 Aug 3, 2017

Contributor

Please checkout the Dokumentation and the prozess ;) without the bigger picture this comment does not help you ;) thanks.

Contributor

zero-24 replied Aug 3, 2017

Please checkout the Dokumentation and the prozess ;) without the bigger picture this comment does not help you ;) thanks.

@BenMitnicK

This comment has been minimized.

Show comment
Hide comment
@BenMitnicK

BenMitnicK Aug 8, 2017

not ok for me with 1&1 database impossible to move in next step I blocked on database I must replace this

if (!in_array($options->db_host, $localhost)) to if(false) for installing joomla 3.7.4

BenMitnicK commented Aug 8, 2017

not ok for me with 1&1 database impossible to move in next step I blocked on database I must replace this

if (!in_array($options->db_host, $localhost)) to if(false) for installing joomla 3.7.4

@wojsmol

This comment has been minimized.

Show comment
Hide comment
@wojsmol
Contributor

wojsmol commented Aug 8, 2017

@zero-24 zero-24 changed the title from fix not installing on remote databases to Joomla is not installing on remote databases Aug 14, 2017

@zero-24 zero-24 modified the milestones: Joomla 3.7.5, Joomla 3.8.0 Aug 14, 2017

rdeutz added a commit that referenced this pull request Aug 17, 2017

fix not installing on remote databases (#17248)
* fix not installing remote databases

* Update database.php

* general remove database message

* Update database.php

# Conflicts:
#	installation/model/database.php
@clx81

This comment has been minimized.

Show comment
Hide comment
@clx81

clx81 Aug 17, 2017

OK, now installation with a localhost is accepted but after the database are filled with tables, the installation come back to the overview, the configuration file is not created !

clx81 commented Aug 17, 2017

OK, now installation with a localhost is accepted but after the database are filled with tables, the installation come back to the overview, the configuration file is not created !

@zero-24

This comment has been minimized.

Show comment
Hide comment
@zero-24

zero-24 Aug 17, 2017

Contributor

@clx81 please open a new issue containing all details what you did and what happend after that so we can try to reproduce and fix the bug. Commenting on closed / merged issues get lost very fast. Thanks for understanding.

Contributor

zero-24 commented Aug 17, 2017

@clx81 please open a new issue containing all details what you did and what happend after that so we can try to reproduce and fix the bug. Commenting on closed / merged issues get lost very fast. Thanks for understanding.

@bettelli

This comment has been minimized.

Show comment
Hide comment
@bettelli

bettelli Aug 18, 2017

hi, can anybody upload the fix, its down https://github.com/zero-24/joomla-cms/archive/fixinstaller.zip 404 not found Thanks

bettelli commented Aug 18, 2017

hi, can anybody upload the fix, its down https://github.com/zero-24/joomla-cms/archive/fixinstaller.zip 404 not found Thanks

@wojsmol

This comment has been minimized.

Show comment
Hide comment
@wojsmol

wojsmol Aug 18, 2017

Contributor

@bettelli This fix is included in Joomla 3.7.5.

Contributor

wojsmol commented Aug 18, 2017

@bettelli This fix is included in Joomla 3.7.5.

@bettelli

This comment has been minimized.

Show comment
Hide comment
@bettelli

bettelli Aug 18, 2017

thanks for the info but i delete the line in database.php and works, i installed from a yootheme template.

bettelli commented Aug 18, 2017

thanks for the info but i delete the line in database.php and works, i installed from a yootheme template.

@zero-24

This comment has been minimized.

Show comment
Hide comment
@zero-24

zero-24 Aug 18, 2017

Contributor

I'm going to lock this issue now. On any questions please open a new issue . Which describes the problem so we can investigate that.

Thanks for understanding.

Contributor

zero-24 commented Aug 18, 2017

I'm going to lock this issue now. On any questions please open a new issue . Which describes the problem so we can investigate that.

Thanks for understanding.

@joomla joomla locked and limited conversation to collaborators Aug 18, 2017

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.