Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
tree: d50fe0744f
Fetching contributors…

Cannot retrieve contributors at this time

68 lines (57 sloc) 1.775 kb
<?php
/**
* @package Joomla.Platform
*
* @copyright Copyright (C) 2005 - 2012 Open Source Matters, Inc. All rights reserved.
* @license GNU General Public License version 2 or later; see LICENSE
*/
// Setup the Pharsanity!
Phar::interceptFileFuncs();
// Set the platform root path as a constant if necessary.
if (!defined('JPATH_PLATFORM'))
{
define('JPATH_PLATFORM', 'phar://' . __FILE__);
}
// Detect the native operating system type.
$os = strtoupper(substr(PHP_OS, 0, 3));
if (!defined('IS_WIN'))
{
define('IS_WIN', ($os === 'WIN') ? true : false);
}
if (!defined('IS_MAC'))
{
define('IS_MAC', ($os === 'MAC') ? true : false);
}
if (!defined('IS_UNIX'))
{
define('IS_UNIX', (($os !== 'MAC') && ($os !== 'WIN')) ? true : false);
}
// Import the platform version library if necessary.
if (!class_exists('JPlatform'))
{
require_once JPATH_PLATFORM . '/platform.php';
}
// Import the library loader if necessary.
if (!class_exists('JLoader'))
{
require_once JPATH_PLATFORM . '/loader.php';
}
// Make sure that the Joomla Platform has been successfully loaded.
if (!class_exists('JLoader'))
{
throw new RuntimeException('Joomla Platform not loaded.');
}
// Setup the autoloaders.
JLoader::setup();
// Import the base Joomla Platform libraries.
JLoader::import('joomla.factory');
// Register classes for compatability with PHP 5.3
if (version_compare(PHP_VERSION, '5.4.0', '<'))
{
JLoader::register('JsonSerializable', JPATH_PLATFORM . '/compat/jsonserializable.php');
}
// Register classes that don't follow one file per class naming conventions.
JLoader::register('JText', JPATH_PLATFORM . '/joomla/language/text.php');
JLoader::register('JRoute', JPATH_PLATFORM . '/joomla/application/route.php');
// End of the Phar Stub.
__HALT_COMPILER();?>
Jump to Line
Something went wrong with that request. Please try again.