Browse files

Added guard for bundler and rspec

  • Loading branch information...
1 parent a0bcde3 commit 2d267b43f3c9177efa8442e066290874bf89cc6b @cinconnu cinconnu committed Jul 25, 2012
Showing with 71 additions and 11 deletions.
  1. +2 −0 .gitignore
  2. +3 −0 .rspec
  3. +19 −1 Gemfile
  4. +35 −10 Gemfile.lock
  5. +12 −0 Guardfile
View
2 .gitignore
@@ -0,0 +1,2 @@
+/.rvmrc
+/.idea/
View
3 .rspec
@@ -0,0 +1,3 @@
+--colour
+--drb
+--format documentation
View
20 Gemfile
@@ -2,5 +2,23 @@ source :rubygems
gemspec # Specify your gem's dependencies in phony_number.gemspec
# For testing
-gem 'rspec'
gem 'sqlite3'
+
+gem 'rspec', '~> 2.11.0'
+gem 'guard', '~> 1.2.0'
+gem 'guard-bundler', '~> 1.0.0'
+gem 'guard-rspec', '~> 1.2.0'
+
+case RbConfig::CONFIG['host_os']
+ when /darwin/i
+ gem 'growl'
+ gem 'rb-fsevent'
+ when /linux/i
+ gem 'libnotify'
+ gem 'rb-inotify'
+ when /mswin|windows/i
+ gem 'rb-fchange'
+ gem 'rb-notifu'
+ gem 'win32console'
+end
+
View
45 Gemfile.lock
@@ -1,7 +1,7 @@
PATH
remote: .
specs:
- phony_rails (0.1.2)
+ phony_rails (0.1.3)
activerecord (~> 3.0)
countries (~> 0.8.2)
phony (~> 1.7.4)
@@ -27,24 +27,49 @@ GEM
currencies (>= 0.2.0)
currencies (0.4.0)
diff-lcs (1.1.3)
+ ffi (1.1.0)
+ guard (1.2.3)
+ listen (>= 0.4.2)
+ thor (>= 0.14.6)
+ guard-bundler (1.0.0)
+ bundler (~> 1.0)
+ guard (~> 1.1)
+ guard-rspec (1.2.0)
+ guard (>= 1.1)
i18n (0.6.0)
+ libnotify (0.7.3)
+ listen (0.4.7)
+ rb-fchange (~> 0.0.5)
+ rb-fsevent (~> 0.9.1)
+ rb-inotify (~> 0.8.8)
multi_json (1.3.6)
- phony (1.7.4)
- rspec (2.10.0)
- rspec-core (~> 2.10.0)
- rspec-expectations (~> 2.10.0)
- rspec-mocks (~> 2.10.0)
- rspec-core (2.10.1)
- rspec-expectations (2.10.0)
+ phony (1.7.7)
+ rb-fchange (0.0.5)
+ ffi
+ rb-fsevent (0.9.1)
+ rb-inotify (0.8.8)
+ ffi (>= 0.5.0)
+ rspec (2.11.0)
+ rspec-core (~> 2.11.0)
+ rspec-expectations (~> 2.11.0)
+ rspec-mocks (~> 2.11.0)
+ rspec-core (2.11.1)
+ rspec-expectations (2.11.1)
diff-lcs (~> 1.1.3)
- rspec-mocks (2.10.1)
+ rspec-mocks (2.11.1)
sqlite3 (1.3.6)
+ thor (0.15.4)
tzinfo (0.3.33)
PLATFORMS
ruby
DEPENDENCIES
+ guard (~> 1.2.0)
+ guard-bundler (~> 1.0.0)
+ guard-rspec (~> 1.2.0)
+ libnotify
phony_rails!
- rspec
+ rb-inotify
+ rspec (~> 2.11.0)
sqlite3
View
12 Guardfile
@@ -0,0 +1,12 @@
+# More info at https://github.com/guard/guard#readme
+
+guard 'bundler' do
+ watch('Gemfile')
+ watch(/^.+\.gemspec/)
+end
+
+guard 'rspec', :version => 2 do
+ watch(%r{^spec/.+_spec\.rb$})
+ watch(%r{^lib/(.+)\.rb$}) { |m| "spec/lib/#{m[1]}_spec.rb" }
+ watch('spec/spec_helper.rb') { "spec" }
+end

0 comments on commit 2d267b4

Please sign in to comment.