Permalink
Commits on May 25, 2012
  1. release 0.4.10

    jordansissel committed May 25, 2012
  2. Update CHANGELIST

    jordansissel committed May 25, 2012
Commits on May 23, 2012
  1. Merge pull request #221 from svenihoney/debian_fix_unequal

    jordansissel committed May 23, 2012
    Introduced a dependency mapping for != dependency using Conflicts in deb instead of a Depends
  2. Merge pull request #208 from jacaetevha/master

    jordansissel committed May 23, 2012
    RPM user and group setting for %files section
Commits on May 17, 2012
  1. Merge pull request #223 from jscheinblum/master

    jordansissel committed May 17, 2012
    Set install-data flag in python setup.py
  2. Set install data location to match install-lib

    jscheinblum committed May 17, 2012
    (distutils default is installation base dir)
Commits on May 15, 2012
  1. Add != dependencies as Conflicts for debian packages

    svenihoney committed May 15, 2012
    Added correct patch now.
  2. Introduced a dependency mapping for != dependency

    svenihoney committed May 15, 2012
    There exist gems in the wild that have a dependency !=
    Example is sprocket gem (at least version 2.1.3). Use a mapping
    that prevents dpkg to choke on != and appended it to the conflicts.
  3. Update CHANGELIST

    jordansissel committed May 15, 2012
  4. - only set permissions/ownership/times if the source and destinations

    jordansissel committed May 15, 2012
      aren't pointing at the same inode.
  5. - Fix versioned downloading for gem and python packages.

    jordansissel committed May 15, 2012
      Tested: fpm -s gem -t deb -v 1.7.1 json
        Successfully installed json-1.7.1
      Tested: fpm -s python -t deb -v 2.1.6 simplejson
      Relevant output:
        Searching for simplejson==2.1.6
        Reading http://pypi.python.org/simple/simplejson/
        Reading http://github.com/simplejson/simplejson
        Reading http://undefined.org/python/#simplejson
        Best match: simplejson 2.1.6
        Downloading
        http://pypi.python.org/packages/source/s/simplejson/simplejson-2.1.6
        .tar.gz#md5=2f8351f6e6fe7ef25744805dfa56c0d5
        Processing simplejson-2.1.6.tar.gz
    
      Related tickets: #215, #204
Commits on May 12, 2012
Commits on May 7, 2012
  1. Merge pull request #212 from Slezhuk/master

    jordansissel committed May 7, 2012
    Fixed python3 incopabilities.
  2. Merge pull request #217 from llasram/master

    jordansissel committed May 7, 2012
    Preserve file metadata (owner, mode, etc) when packaging directories.
Commits on May 6, 2012
Commits on Apr 26, 2012
  1. Update CHANGELIST

    jordansissel committed Apr 26, 2012
  2. Merge pull request #213 from UnifiedPost/develop

    jordansissel committed Apr 26, 2012
    Fixed the path_prefix to prefix to allow overriding the gem path
Commits on Apr 25, 2012
  1. modified: lib/fpm/package/pyfpm/get_metadata.py

    Slezhuk Evgeniy committed Apr 25, 2012
    	modified:   lib/fpm/package/python.rb
    
    Added python3 support. Useful for packaging python3 projects. For example:
    fpm -s python -t deb --python-bin /usr/bin/python3 myproject/setup.py
  2. update version

    jordansissel committed Apr 25, 2012
  3. version bump

    jordansissel committed Apr 25, 2012
  4. update changelist

    jordansissel committed Apr 25, 2012
  5. - Make gem 'provides' really provide 'rubygem-foo'

    jordansissel committed Apr 25, 2012
    - When converting gem->rpm, turn 'rubygem-foo' provides into
      'rubygem(foo)'
  6. Merge pull request #198 from mv/master

    jordansissel committed Apr 25, 2012
    Warning: already initialized constant
Commits on Apr 18, 2012
  1. add specs for user and group settings

    Jason Rogers committed Apr 18, 2012
Commits on Apr 13, 2012
  1. Merge pull request #194 from lum/master

    jordansissel committed Apr 13, 2012
    Adding the noreplace option to config files in the rpm spec template.
  2. Merge pull request #206 from specialunderwear/master

    jordansissel committed Apr 13, 2012
    Python packages that are pinned to a specific version can not be packaged as .deb