Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Dependent gem json's update breaks fpm gem install on ruby < 2.0 #1147

Closed
sarguru opened this issue Jul 1, 2016 · 5 comments

Comments

@sarguru
Copy link

@sarguru sarguru commented Jul 1, 2016

Json's new release needs ruby > 2.0, so it breaks places in which older version of ruby is used. Is it possible to do something like

spec.add_dependency("json", ">= 1.7.7", "< 2") ?

The current workaround Im doing is to

gem install json -v 1.8.3 before
gem install fpm

@jordansissel

This comment has been minimized.

Copy link
Owner

@jordansissel jordansissel commented Jul 1, 2016

#1146 just merged to fix this.

@jordansissel

This comment has been minimized.

Copy link
Owner

@jordansissel jordansissel commented Jul 1, 2016

fpm 1.6.2 published with this fix.

@jordansissel

This comment has been minimized.

Copy link
Owner

@jordansissel jordansissel commented Jul 1, 2016

Or not... gem push is stuck on my workstation. I'll publish as soon as I can :\

@jordansissel

This comment has been minimized.

Copy link
Owner

@jordansissel jordansissel commented Jul 1, 2016

% gem push fpm-1.6.2.gem
Pushing gem to https://rubygems.org...
Successfully registered gem: fpm (1.6.2)

wooo

@sarguru

This comment has been minimized.

Copy link
Author

@sarguru sarguru commented Jul 1, 2016

<3

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.