Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

install rpm error #321

Closed
bjjasonzhao opened this issue Dec 24, 2012 · 3 comments

Comments

@bjjasonzhao
Copy link

@bjjasonzhao bjjasonzhao commented Dec 24, 2012

my os is centos 5.6 x86_64

rpm package finsh and begin install rpm package error:

command: rpm -ivh memcached-1.4.5-1.x86_64.rpm
Preparing... ########################################### [100%]
package memcached-1.4.5-1.x86_64 is intended for a operating system

@kevinburke

This comment has been minimized.

Copy link

@kevinburke kevinburke commented Dec 25, 2012

I ran into the same issue and I believe the problem is related to #309. You need to specify --rpm-os linux or whatever when using the latest version of fpm, to specify the correct operating system.

@jordansissel

This comment has been minimized.

Copy link
Owner

@jordansissel jordansissel commented Dec 25, 2012

Yeah, this is a bug. Sorry about this :|

The --rpm-os linux workaround should be sufficient. Alternately, downgrading to fpm 0.4.24.

I'll have a proper fix released in a few days I hope (busy with sysadvent lately)

@bjjasonzhao

This comment has been minimized.

Copy link
Author

@bjjasonzhao bjjasonzhao commented Dec 25, 2012

thx, my Problem is solved

prof-milki pushed a commit to prof-milki/xpm that referenced this issue Dec 18, 2014
prof-milki pushed a commit to prof-milki/xpm that referenced this issue Dec 27, 2014
jordansissel added a commit that referenced this issue Apr 24, 2015
jordansissel added a commit that referenced this issue Jun 20, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.