Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

gnutar missing in OS X 10.9 #576

Closed
nandosola opened this Issue Oct 24, 2013 · 3 comments

Comments

Projects
None yet
4 participants

After installing the latest, shiniest OS X 10.9 (aka Mavericks), I get this error when I build my DEB packages:

{:timestamp=>"2013-10-24T09:52:44.638000+0200", :message=>"Need executable 'gnutar' to convert dir to deb", :level=>:error}

Just for the record, there's some discussion already on this topic. For me, the solution was:

xcode-select --install
sudo ln -s /usr/bin/tar /usr/bin/gnutar
sudo port install gnutar
sudo rm /usr/bin/gnutar

So that FPM uses the real gnutar binary in MacPorts.

james4k commented Nov 3, 2013

Can confirm the same thing here.

If you're using Homebrew, an option for now:

brew install gnu-tar
ln -s /usr/local/bin/gtar /usr/local/bin/gnutar

Looks like 80ee8ae should fix this?

Owner

jordansissel commented Oct 25, 2014

Marking resolved based on previous comment. Also my intention is to move to pure-ruby tar implementation (#785) so hopefully this won't ever be a problem again :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment