Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

fix: install loop problem in rpm.erb #1434

Merged

Conversation

@schmto
Copy link
Contributor

schmto commented Nov 6, 2017

When using install command (from /usr/bin/install) in after_install
shell in creates a endless loop, because it jumps to funtion beginning
of install(). So it's best practise to rename it to _install() to avoid
collision with /usr/bin/install command

When using install command (from /usr/bin/install) in after_install
shell in creates a endless loop, because it jumps to funtion beginning
of install(). So it's best practise to rename it to _install() to avoid
collision with /usr/bin/install command
@jordansissel

This comment has been minimized.

Copy link
Owner

jordansissel commented Dec 23, 2017

I haven't tested, but the change looks good to me.

@jordansissel jordansissel merged commit c4b3cd8 into jordansissel:master Dec 23, 2017
1 check failed
1 check failed
continuous-integration/travis-ci/pr The Travis CI build failed
Details
@schmto

This comment has been minimized.

Copy link
Contributor Author

schmto commented Dec 26, 2017

yes. it works for me. tested on two different hosts.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.