Skip to content

Fixed gem ~> version operator translated to rpm require. #193

Merged
merged 1 commit into from Apr 1, 2012

2 participants

@antoncohen

In gem specs ~> is a Pessimistic Version Consrtaint that is inclusive
on the bottom end. E.g., '~> 2.2' means '>= 2.2.0 and < 3.0'.

I changed the translation to RPM spec to be >= and <. It was > and <.

http://docs.rubygems.org/read/chapter/16
http://docs.fedoraproject.org/en-US/Fedora_Draft_Documentation/0.1/html/RPM_Guide/ch-advanced-packaging.html

@antoncohen antoncohen Fixed gem ~> version operator translated to rpm require.
In gem specs ~> is a Pessimistic Version Consrtaint that is inclusive
on the bottom end. E.g., '~> 2.2' means '>= 2.2.0 and < 3.0'.

I changed the translation to RPM spec to be >= and <. It was > and <.

http://docs.rubygems.org/read/chapter/16
http://docs.fedoraproject.org/en-US/Fedora_Draft_Documentation/0.1/html/RPM_Guide/ch-advanced-packaging.html
171ad00
@jordansissel
Owner

LGTM. Thanks for this fix :)

@jordansissel jordansissel merged commit 918e8c9 into jordansissel:master Apr 1, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.