Skip to content
Permalink
Browse files

Merge branch 'release/1.0.3'

  • Loading branch information...
jormar committed Oct 30, 2016
2 parents 11f8725 + edd6eb7 commit 27a9c92bff9785286faca4ca4df44e7ae1bc6c7a
Showing with 41 additions and 2 deletions.
  1. +40 −1 README.md
  2. +1 −1 package.json
@@ -5,12 +5,24 @@ Update confluence pages from your markdown files (like a README.md)

### Install the package

Although you can use this package like any other package, it's intended to development environments and I recommend to install it as dev dependency:

You can safely install it as a global package:

```bash
npm install -g md2confluence
```
This will allow you to use the command ```md2confluence``` anywhere.

But, it's intended to development environments and I recommend to install it as dev dependency:

```bash
npm install --save-dev md2confluence
```

...and excecuting it as a npm script.


### Create the .md2confluence-rc file

It's mandatory. It looks like:
@@ -55,6 +67,33 @@ The path to the file in Markdown format with the content to update the page.
It's relative to the dir where you run the command.


### Excecute as a node app

You can use the command in the working directory (if it was installed globally):

```bash
md2confluence
```

Or exceute it from your node_modules in your working directory (installed locally):

```bash
node_modules/.bin/md2confluence
```

Or you can add this like a npm script in your package.json (recommended if it was installed as devDependencies):

```javascript
{
...
"scripts": {
"pushdoc": "md2confluence"
},
...
}
```


## Need new features?

Please, feel free to create any issues and pull request that you need.
@@ -1,6 +1,6 @@
{
"name": "md2confluence",
"version": "1.0.2",
"version": "1.0.3",
"description": "Update confluence pages from your markdown files (like a README.md)",
"main": "dist/index.js",
"bin": {

0 comments on commit 27a9c92

Please sign in to comment.
You can’t perform that action at this time.